Microsoft Systems Management Server 2003 Management Pack pour Microsoft Operations Manager 2007

Microsoft® Systems Management Server 2003 Management Pack pour Microsoft Operations Manager 2007 comporte de nouvelles fonctionnalités d'analyse de SMS 2003 et d'autres qui ont été améliorées.

Ressources

Pour plus d'informations sur les fonctionnalités et ressources, voir les rubriques ci-après.

Présentation du Systems Management Server 2003 Management Pack

  • Scénarios d'analyse du pack d'administration

  • Déploiement du SMS 2003 Management Pack

  • Exécution de tâches d'opération pour le SMS 2003 Management Pack

  • Dépannage du SMS 2003 Management Pack

  • Références du Microsoft Systems Management Server 2003 Management Pack


Présentation du Systems Management Server 2003 Management Pack

Ce guide contient des informations sur les aspects techniques et le déploiement de SMS 2003 Management Pack. Ces informations vous permettront de planifier le déploiement du pack d'administration et de mieux comprendre les fonctionnalités et avantages offerts par celui-ci à votre infrastructure informatique.

System Center Operations Manager 2007 Management Pack pour SMS comporte des fonctionnalités d'analyse de SMS 2003 qui ont été améliorées, notamment :

  • Analyse du démarrage et de l'arrêt de tous les services SMS 2003, y compris les services associés essentiels tels que WMI (Windows Management Instrumentation), les services Internet (IIS), le service de transfert intelligent en arrière-plan (BITS) et Microsoft SQL Server™

  • Envoi à l'administrateur SMS de messages d'alerte critiques relatifs à l'état de SMS

  • Analyse des retards de traitement des enregistrements de données de découverte (DDR), de l'inventaire logiciel, de l'inventaire matériel, des messages d'état et du contrôle de logiciel sur les serveurs de site principal et les points de gestion

  • Analyse de l'utilisation des ressources système

  • Analyse des taux de traitement

  • Analyse des tendances de nombreux compteurs de performance SMS grâce aux affichages et aux rapports

  • Base de connaissances du produit relative à toutes les alertes et aux règles de traitement

  • Détection de tous les ordinateurs et groupes d'ordinateurs SMS 2003

  • Affichages

  • Rapports affichant les performances, la disponibilité et la configuration des points de gestion et groupes de serveurs SMS 2003 (y compris les rapports liés fournissant des informations sur les tendances de disponibilité, de configuration et de performances de Systems Center Operations Manager 2007)

  • Analyse du Device Management Feature Pack

  • Tâches permettant d'exécuter les applications de la console Administrateur SMS

  • Affichage de l'état de fonctionnement de tous les rôles serveur SMS et du client avancé SMS

  • Découverte de service visant à recueillir des informations importantes sur les clients et les serveurs SMS

  • Suppression des alertes d'indisponibilité de service déclenchées par l'exécution de la sauvegarde de site SMS

  • Topologie de la hiérarchie de sites SMS (SMS 2003 Service Pack 3 est requis)

  • Génération d'alertes configurable pour SMS 2003 Service Pack 3 (SP3) concernant l'échec d'exécution de programmes distribués via les propriétés du programme SMS

Pour plus d'informations sur les fonctionnalités et les scénarios d'analyse, voir la section Scénarios d'analyse du pack d'administration, plus loin dans ce guide. SMS 2003 Management Pack n'est pas conçu pour :

  • analyser les versions SMS 1.2, SMS 2.0 et SMS 2003 SP2 ;

  • analyser les environnements SMS mixtes (comprenant des installations SMS 1.2, SMS 2.0 et SMS 2003) ;

  • analyser les problèmes sur des ordinateurs clients SMS uniquement exécutant le client avancé SMS ;

  • fournir une solution d'analyse prête à l'emploi qui gère tout type d'installation SMS 2003 sans modification aucune (les seuils des règles sont différents pour chaque installation SMS 2003 et doivent être personnalisés par les clients eux-mêmes).

Dans cette section

Nouveautés de cette mise à jour

Connaissances recommandées

Configuration de SMS prise en charge

Voir aussi

Concepts

Scénarios d'analyse du pack d'administration
Déploiement du SMS 2003 Management Pack

Autres ressources

Exécution de tâches d'opération pour le SMS 2003 Management Pack
Dépannage du SMS 2003 Management Pack
Références du Microsoft Systems Management Server 2003 Management Pack


Nouveautés de cette mise à jour

Systems Management Server 2003 Management Pack pour Microsoft Operations Manager 2007 propose un mode maintenance. Le mode maintenance supprime les alertes Microsoft Operations Manager envoyées par les ordinateurs clients lorsqu'ils exécutent les logiciels SMS.

Mettre à jour le mode maintenance pour SMS 2003

Lorsque Systems Management Server 2003 distribue des logiciels aux ordinateurs, il est souvent nécessaire de désactiver temporairement les alertes basées sur les règles Microsoft Operations Manager générées par l'ordinateur cible. Le déploiement de correctifs logiciels et de mises à jour de sécurité sur des serveurs, par exemple, peut exiger l'arrêt des threads et des services. Si les threads ou services de ces serveurs sont analysés par un pack d'administration, de nombreuses alertes Microsoft Operations Manager risquent d'être générées, ce qui peut entraîner une surcharge du serveur Microsoft Operations Manager.

L'option Désactiver les alertes MOM lors de l'exécution de ce programme permet d'interrompre la génération d'alertes Microsoft Operations Manager jusqu'à la fin de la distribution des logiciels. L'administrateur SMS peut activer cette case à cocher dans les propriétés du programme de package SMS. L'activation de cette option permet de supprimer les alertes Microsoft Operations Manager pour tous les packs d'administration qui analysent l'ordinateur client pendant que celui-ci exécute le programme.

Si cette option est activée, l'Agent Microsoft Operations Manager est mis en mode maintenance lorsque la publication est en cours d'exécution sur l'ordinateur cible. L'agent SMS propose également un paramètre de délai pour l'Agent Microsoft Operations Manager. Une fois l'exécution de la publication terminée sur l'ordinateur cible, l'agent SMS permet à l'Agent Microsoft Operations Manager de reprendre l'analyse de l'ordinateur. Toutes les alertes déclenchées par des événements sont alors signalées normalement.

Si la distribution de logiciels ne peut pas s'exécuter sur l'ordinateur cible, les actions suivantes sont effectuées :

  • Si la distribution renvoie un code d'échec, l'agent SMS fait en sorte que l'Agent Microsoft Operations Manager quitte le mode maintenance comme si la distribution avait réussi.

  • Si la distribution échoue de manière inattendue et si l'agent SMS ne reçoit aucun code d'échec dans le délai spécifié, l'Agent Microsoft Operations Manager quitte le mode maintenance.

Activer le mode maintenance pour un programme SMS 2003

Suivez la procédure décrite ci-après pour activer le mode maintenance sur les ordinateurs clients lors de l'exécution des programmes SMS 2003.

Pour activer le mode maintenance pour un programme SMS 2003

  1. Dans la console SMS, accédez à Systems Management Server / Base de données du site - <nom du serveur de site> / Packages.

  2. Dans le volet d'informations, cliquez avec le bouton droit sur le programme, puis cliquez sur Propriétés.

  3. Dans la boîte de dialogue Propriétés du programme, cliquez sur l'onglet Microsoft Operations Manager.

  4. Activez la case à cocher Désactiver les alertes MOM lors de l'exécution de ce programme, puis cliquez sur OK.

Une fois le mode maintenance activé pour le programme SMS 2003, l'ordinateur client bascule en mode maintenance lors de la distribution et l'exécution du package SMS 2003.

Remarque
La durée du mode maintenance est définie sous l'onglet Spécifications de la boîte de dialogue Propriétés du programme à l'aide de la sélection de la propriété Maximum allowed runtime.

Topologie de sites SMS 2003

Les diagrammes hiérarchiques SMS 2003 de Microsoft Operations Manager (MOM) 2005 ont été remplacés par une hiérarchie de sites SMS 2003. L'affichage hiérarchique montre désormais les rôles serveur dans l'affichage de topologie.

Suppression des scripts de configuration

L'utilisation de SMS 2003 SP2 ou version ultérieure étant recommandée, les scripts de configuration ont été supprimés.

Rapports SMS 2003

SMS 2003 propose de nouveaux rapports axés sur les compteurs de performance par rôle du système de site et par compteur de traitement d'objets, tels que les compteurs associés aux enregistrements de données de découverte. Pour plus d'informations sur les nouveaux rapports, voir la section Rapports SMS 2003.

Voir aussi

Concepts

Rapports SMS 2003

Autres ressources

Scripts pour SMS 2003


Connaissances recommandées

Pour déployer et exécuter le SMS 2003 Management Pack, il est recommandé de disposer des connaissances et compétences ci-dessous :

  • Connaître activement les fonctions d'analyse d'Operations Manager 2007. Pour plus d'informations sur Operations Manager 2007, voir la page Web Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).

  • Comprendre l'architecture de conception d'Operations Manager 2007 et celle déployée dans votre organisation.

  • Être familier avec la procédure recommandée à suivre pour déployer les packs d'administration (voir le guide de déploiement de System Center Operations Manager 2007).

  • Connaître activement les concepts et les termes liés à SMS. Pour plus d'informations sur SMS 2003, voir la page Web Documentation du produit SMS 2003 (http://go.microsoft.com/fwlink/?linkid=9502).

Voir aussi

Concepts

Scénarios d'analyse du pack d'administration
Déploiement du SMS 2003 Management Pack

Autres ressources

Exécution de tâches d'opération pour le SMS 2003 Management Pack


Configuration de SMS prise en charge

La configuration requise pour SMS 2003 et pour Systems Center Operations Manager 2007 est détaillée dans leur guide de déploiement respectif. Le SMS 2003 Management Pack surveille SMS 2003. SMS 2003 SP2 et les versions ultérieures sont recommandées. L'exécution de SMS 2003 SP1 requiert l’exécution d'un script de marquage.

L’activation du mode de maintenance pendant la distribution des logiciels et le mappage de la topologie avec Operations Manager 2007 requièrent SMS 2003 SP3 ou version ultérieure.

Ce SMS 2003 Management Pack ne surveille pas SMS 1.2, SMS 2.0 ou Configuration Manager 2007.

Voir aussi

Autres ressources

Références du Microsoft Systems Management Server 2003 Management Pack
Dépannage du SMS 2003 Management Pack


Scénarios d'analyse du pack d'administration

Microsoft® Systems Management Server (SMS) 2003 apporte des améliorations par rapport aux fonctionnalités existantes et propose aussi de nouvelles fonctionnalités d'analyse de SMS 2003. Les sections ci-après décrivent les principaux scénarios pris en charge par SMS 2003 Management Pack, ainsi que leurs fonctionnalités.

Disponibilité des services

Découverte des services

Contrôle de la disponibilité

Analyse de l'état

Prise en charge de l’analyse sans agent

Surveillance du seuil de performance

Analyse des performances

Surveillance des messages d’état SMS critiques

contrôle du système du site

Analyse des vidages sur incident Executive

Analyse des retards de traitement

Surveillance de l’état général

Surveillance de la gestion de correctif SMS

Surveillance de la sauvegarde de site SMS

Contenu de la base de connaissances du produit pour toutes les alertes

Groupes d'ordinateurs pour tous les rôles serveur et client SMS 2003

Surveillance étendue

État d’exécution du programme de distribution de logiciels

Disponibilité des services

La disponibilité des services SMS 2003 est analysée à l'aide de la fonctionnalité de disponibilité des services de System Center Operations Manager 2007 et des événements du Gestionnaire de contrôle des services du journal des événements système Windows NT. L'analyse de la disponibilité des services génère :

  • une alerte lors de l'arrêt de services SMS sur des systèmes de site SMS ;

  • une alerte lorsqu'un service essentiel associé à SMS, comme le service WMI, s'arrête ou ne parvient pas à démarrer sur des systèmes de site SMS ;

  • une alerte lorsque d'autres services associés à SMS, comme Microsoft SQL Server™, les services Internet (IIS) et le service de transfert intelligent en arrière-plan (BITS), s'arrêtent ou ne parviennent pas à démarrer sur des systèmes de site SMS ;

  • une alerte lors du démarrage ou de l'arrêt du service de sauvegarde de site SMS afin que vous puissiez analyser les durées de sauvegarde et établir une corrélation entre des événements d'arrêt d'autres services SMS et la sauvegarde de site SMS.

Découverte des services

La découverte de service consiste à découvrir les données, les rôles serveur et les composants des ordinateurs gérés. Elle renvoie des informations sur les clients avancés et les serveurs SMS. Elle prend également en charge la présentation des rôles des clients et des serveurs SMS dans l'affichage de l'analyse d'état.

Les données de découverte de service spécifiques aux serveurs sont collectées et commencent à apparaître dans la console System Center Operations dès le déploiement du pack d'administration. De nombreuses fonctionnalités exigeant l'identification des rôles, des groupes d'ordinateurs et des ordinateurs cibles pour permettre la réalisation de tâches spécifiques ne sont disponibles qu'une fois la première collecte des données de découverte de service effectuée.

SMS 2003 Management Pack utilise les règles de traitement des événements suivantes pour lancer les scripts de découverte de service :

  • Clients SMS\Clients SMS - Avancé\Découverte de service SMS 2003

  • Serveurs SMS\Serveurs SMS - Commun\Découverte de service SMS 2003

Les scripts utilisent un fournisseur d'événement chronométré asynchrone pour collecter les données de découverte de service toutes les 24 heures, par défaut. Le fournisseur se charge également d'effectuer les actions suivantes :

  • Déploiement du pack d'administration

  • Modifications de configuration du pack d'administration

  • Démarrage et arrêt de l'Agent Microsoft Operations Manager 2007

Contrôle de la disponibilité

Cette version de SMS Management Pack comporte trois rapports de disponibilité : Rapport de disponibilité des serveurs SMS 2003, Rapport de disponibilité du point de gestion SMS 2003 et Rapport de disponibilité du serveur de site SMS 2003.

Le Rapport de disponibilité du point de gestion est un rapport de disponibilité reposant sur le fonctionnement de composants. La disponibilité des points de gestion repose sur un nouvel algorithme, de nouvelles règles et le script SMS 2003 Monitor Management Point Availability.

Tous les rapports, y compris ceux dont il est fait référence dans cette section, s'exécutent sur la base de données OperationsManager, ce qui permet de spécifier des durées de rapports supérieures par rapport au script précédent qui créait les procédures stockées dans la base de données OperationsManager uniquement.

Pour plus d'informations sur la disponibilité des serveurs, voir les sections Scripts pour SMS 2003 et Rapports SMS 2003 de ce guide.

Analyse de l'état

L'analyse de l'état fournit une représentation graphique du fonctionnement de tous les serveurs ou de serveurs relatifs à certains groupes d'ordinateurs spécifiques. Le pack d'administration prend en charge cette fonctionnalité avec une liste spécifique de groupes d'ordinateurs. Les rôles de serveur et les composants sont gérés par l'intermédiaire de la découverte de service tandis que le fonctionnement des composants est géré par un ensemble de règles qui vérifient la disponibilité des services, les seuils de performance et le fonctionnement des points de gestion.

Le tableau ci-dessous indique les états de fonctionnement qui sont analysés pour les composants SMS par couleur.

Tableau 1: Analyse de l'état du serveur SMS

Composant SMS | Vert (Réussite) | Jaune (Avertissement) | Rouge (Critique)
Serveur de site (SS) | Oui | Oui | Oui
Point de gestion (MP) | Oui | Oui | Oui
Base de données du site (DB) | Oui | Oui | Oui
Point de distribution (DP) | Oui |  |
Point de recherche de serveur (SLP) | Oui |  | Oui
Expéditeur | Oui |  | Oui
Point de rapport (RP) | Oui |  | Oui
Fournisseur | Oui |  | Oui
Point d'accès client (CAP) | Oui |  | Oui
Performances | Oui | Oui | Oui
Remarque
Il n'existe aucune règle d'analyse permettant de modifier l'état du composant de point de distribution. Dès lors, si le composant est installé, il est indiqué avec un état vert uniquement. S'il n'est pas installé, l'état de fonctionnement n'apparaît pas dans la console.

Analyse de l'état du client SMS

Composant SMS | Vert (Réussite) | Jaune (Avertissement) | Rouge (Critique)
Service client | Oui |  | Oui

Prise en charge de l’analyse sans agent

SMS 2003 Management Pack prend en charge l'analyse sur des ordinateurs gérés sans agent à l'exception des fonctionnalités répertoriées ci-dessous :

  • Analyse de messages d'état SMS critique

  • Analyse de l'état du système de site

  • Topologie

Les scripts qui prennent en charge les fonctionnalités précitées sont les suivants :

  • SMS 2003 Monitor SMS Status Messages

  • SMS 2003 Monitor Site System Summarizer

  • SMS 2003 Server Topology: Discovery

Ces scripts doivent être exécutés localement sur le fournisseur SMS pour accéder à l'espace de noms SMS. Si les scripts ne peuvent pas localiser cet espace de noms SMS, un événement d'erreur de script se produit.

Surveillance du seuil de performance

Une diminution des niveaux de performance peut être à l'origine de retards et affecter les contrats de niveau de service (SLA) en termes de temps, de performances et de précision des données. Il est important de détecter et résoudre les problèmes de performance graves au sein de l'infrastructure SMS. L'analyse des seuils de performance génère une alerte dans les cas suivants :

  • Les mesures de fonctionnement général de l'ordinateur relatives à l'UC, au fichier d'échange et à la mémoire sur des systèmes de site SMS dépassent certains seuils.

  • Le nombre total de connexions utilisateur Microsoft SQL Server™ dépasse un seuil défini.

  • Le nombre total de fichiers SMS [tels que travaux du planificateur, demandes d'expédition, enregistrements de contrôle de logiciel, enregistrements de données de découverte (DDR) et enregistrements d'inventaire logiciel et matériel] dépasse certains seuils dans les boîtes de réception de serveurs de site SMS.

  • Le nombre total de messages SMS relatifs aux messages d'état, aux enregistrements de données de découverte, aux inventaires logiciel et matériel dans les files d'attente de messages de point de gestion SMS dépasse certains seuils.

Analyse des performances

L'analyse des performances vous permet d'observer des tendances dans les retards de traitement, les taux de traitement et les totaux d'objets SMS clés pour identifier et résoudre les problèmes de façon proactive. À l'aide des affichages et rapports Microsoft Operations Manager 2007, vous pouvez obtenir une analyse sous forme graphique des tendances suivantes :

  • Fichiers en retard de traitement dans les boîtes de réception et concernant les travaux du planificateur, les demandes d'expédition, les enregistrements de contrôle de logiciel, les enregistrements de découverte de données, les inventaires matériel et logiciel ainsi que les messages d'état sur les serveurs de site SMS.

  • Taux de traitement des travaux du planificateur, des demandes d'expédition, des enregistrements de contrôle de logiciel, des enregistrements de découverte de données, des inventaires matériel et logiciel et des messages d'état sur les serveurs de site SMS.

  • Nombre total des travaux du planificateur, des demandes d'expédition, des enregistrements de contrôle de logiciel, des enregistrements de découverte de données, des inventaires matériel et logiciel et des messages d'état sur les serveurs de site SMS.

  • Retards de traitement concernant les enregistrements de découverte de données, les inventaires matériel et logiciel, le contrôle de logiciel, les messages d'état ainsi que d'autres objets SMS dans les files d'attente de messages de serveur de point de gestion SMS.

  • Taux de traitement des enregistrements de découverte de données, des inventaires matériel et logiciel, du contrôle de logiciel, des messages d'état ainsi que d'autres objets SMS dans les files d'attente de messages de serveur de point de gestion SMS.

  • Totaux des enregistrements de découverte de données, des inventaires matériel et logiciel, des relais et des messages d'état dans les files d'attente de messages de serveur de point de gestion SMS.

  • Nombre total de connexions utilisateur SQL Server sur les serveurs de base de données du site SMS.

  • Mesures de fonctionnement général de l'ordinateur relatives à l'UC, au fichier d'échange et à la mémoire sur des systèmes de site SMS.

  • Nombre total de threads SMS Executive en cours d'exécution.

  • Taux des demandes d'extension ISAPI adressées aux services Internet (IIS).

Surveillance des messages d’état SMS critiques

L'infrastructure SMS génère des messages d'état SMS. Il est important d'identifier les messages d'état SMS critique relatifs aux serveurs SMS et de les résoudre dans les plus brefs délais. Ces messages signalent généralement des problèmes de disponibilité, de performances, de configuration et de fonctionnement général de l'infrastructure SMS.

L'analyse des messages d'état SMS critique génère une alerte lors de la détection de messages d'état essentiels au fonctionnement du rôle de site SMS (par exemple l'installation d'un composant ou la connectivité de la base de données et du site). Toutes les demi-heures, une recherche de messages d'état SMS critique est effectuée sur la base de données du site SMS.

Analyse de l'état du système de site

SMS analyse périodiquement le fonctionnement élémentaire de ses systèmes de site via l'outil de synthèse d'état du système de site, qui interroge les systèmes de site SMS à l'heure juste, toutes les heures. Pour tirer parti de cette fonctionnalité, vous devez réagir rapidement en présence de cet état afin d'éviter toute dégradation des fonctionnalités de SMS. L'analyse de l'état du système de site offre la possibilité de contrôler et de générer une alerte lors de la détection d'un état critique de fonctionnement du système de site SMS par l'outil de synthèse du système de site SMS. Parmi les messages d'état, citons notamment une défaillance du système de site SMS, un espace de base de données ou de fichiers journaux insuffisant sur un serveur exécutant SQL Server ou un espace disque insuffisant pour des systèmes de site SMS.

Analyse des vidages sur incident Executive

Les échecs du service SMS Executive ont un impact sur la disponibilité de SMS. Il est donc important d'être averti dès que des vidages sur incident ont lieu et d'en rechercher les causes. Lorsque le service SMS Executive échoue, il crée un sous-répertoire de journaux pour les vidages sur incident sous le répertoire SMS\Logs\CrashDumps. Dès que ce sous-répertoire est créé, une alerte est générée pour les rôles serveur SMS associés au service SMS Executive.

Le script SMS 2003 Monitor SMS Executive Crash Dumps signale uniquement le vidage sur incident le plus récent. Cette règle s'applique quelle que soit la date du dernier vidage sur incident (de la première exécution du script à la désinstallation et réinstallation du service SMS Executive).

Les règles associées figurent dans le groupe de règles Serveurs de composants Microsoft SMS 2003 basés sur SMS Executive :

  • Vidages sur incidents SMS 2003 : surveillance de SMS Executive

Vidages sur incidents SMS 2003 : surveillance de SMS Executive exécute le script à l'aide du fournisseur d'événement chronométré SMS 2003 Planifiez toutes les 60, synchronisez à 00:10. Des informations de synthèse sont fournies dans la page de propriétés Base de connaissances de la règle.

  • Vidages sur incidents SMS 2003 : Erreur de script de surveillance de SMS Executive

Vidages sur incidents SMS 2003 : erreur de script de surveillance de SMS Executive analyse les événements d'erreur de script qui peuvent être déclenchés et envoie une alerte. Seul l'événement lié à un script erroné (numéro 1102) signale toutes les erreurs de script. Des informations sur la résolution de cette alerte sont fournies dans la page de propriétés Base de connaissances de la règle.

  • Vidages sur incidents SMS 2003 : incident SMS Executive

Vidages sur incidents SMS 2003 : incident SMS Executive analyse l'événement de vidage sur incident et envoie une alerte. Des informations sur la résolution de cette alerte sont fournies dans la page de propriétés Base de connaissances de la règle.

Analyse des retards de traitement

Les retards de traitement sont à l'origine de délais qui affectent les contrats de niveau de service (SLA) en termes de temps, de performances et de précision des données. Il est important de détecter et résoudre rapidement les problèmes de performance graves au sein de l'infrastructure SMS. Une alerte est générée en présence d'un retard de traitement supérieur à un seuil donné pendant une période définie pour les éléments suivants :

  • Nombre total de fichiers SMS [tels que travaux du planificateur, demandes d'expédition, enregistrements de contrôle de logiciel, enregistrements de données de découverte (DDR) et enregistrements d'inventaire logiciel et matériel] dans les boîtes de réception des serveurs de site SMS.

  • Nombre total d'objets SMS [tels que travaux du planificateur, demandes d'expédition, enregistrements de contrôle de logiciel, enregistrements de données de découverte (DDR) et enregistrements d'inventaire logiciel et matériel] dans les files d'attente des serveurs de site SMS.

Nombre total de messages SMS relatifs aux messages d'état, aux enregistrements de données de découverte, aux inventaires logiciel et matériel dans les files d'attente de messages de point de gestion SMS.

Surveillance de l’état général

L'analyse du fonctionnement général génère une alerte lorsqu'une mesure de fonctionnement d'un serveur SMS est supérieure à un seuil donné pendant une période définie. Elle vérifie les mesures suivantes :

  • Temps processeur à 95 % pendant plus de trois heures

    • Smsexec

    • Ccmexec

    • Total

  • Utilisation du fichier d'échange à 98 % pendant plus de trois heures

Surveillance de la gestion de correctif SMS

Les administrateurs SMS dépendent des fonctionnalités de gestion de correctifs SMS pour garantir la présence des mises à jour de sécurité les plus récentes sur les ordinateurs clients et serveur de leur entreprise. L'analyse de la gestion des correctifs détecte tout problème dans la configuration et le traitement de la gestion de correctifs SMS. Elle génère une alerte dans les cas suivants :

  • Le processus de synchronisation de la gestion de correctifs SMS échoue.

  • Le processus de gestion des correctifs SMS ne parvient pas à mettre à jour des points de distribution SMS.

Surveillance de la sauvegarde de site SMS

Les administrateurs SMS peuvent plus facilement effectuer l'audit des activités de sauvegarde lorsqu'ils savent à quel moment la sauvegarde SMS 2003 a commencé, s'est terminée ou a échoué. Vous pouvez planifier l'exécution périodique de la sauvegarde SMS pour sauvegarder les données, les stratégies et la configuration de SMS. Il est important d'analyser les échecs de ce processus de sauvegarde et de prendre les mesures qui s'imposent dans ce cas. Même en cas de réussite, la sauvegarde SMS affecte la disponibilité des services, car elle arrête et démarre les services Gestionnaire de composants de site SMS, SMS Executive et Moniteur SQL SMS. L'analyse de la sauvegarde SMS permet d'identifier les temps d'inactivité de ces services, car les alertes relatives à l'arrêt de ces services sont supprimées pendant le processus de sauvegarde. L'analyse de la sauvegarde de site SMS est prise en charge par les règles suivantes :

  • Arrêt du service SMS 2003 exécutant : SMS_SITE_BACKUP

  • Démarrage du service SMS 2003 exécutant : SMS_SITE_BACKUP

  • État de SMS 2003 : la sauvegarde du site s’est correctement effectuée

  • État de SMS 2003 : la sauvegarde du site a échoué

Contenu de la base de connaissances du produit pour toutes les alertes

Les administrateurs peuvent consulter la Base de connaissances du produit comprenant toutes les alertes afin d'identifier et de résoudre plus facilement un problème. Pour accéder à cette Base de connaissances, cliquez avec le bouton droit sur le nom d'une règle, cliquez sur Propriétés, puis sur l'onglet Base de connaissances du produit.

Groupes d'ordinateurs pour tous les rôles serveur et client SMS 2003

La résolution de groupes d'ordinateurs est désormais associée à des rôles serveur et client SMS spécifiques. Les administrateurs disposent ainsi d'un meilleur contrôle de la réplication de règles vers les agents Microsoft Operations Manager 2007. Ils peuvent désactiver les groupes d'ordinateurs par défaut ou définir de nouveaux groupes selon les groupes d'ordinateurs et les attributs d'ordinateur par défaut.

Surveillance étendue

Les règles de SMS 2003 Management Pack englobent les services de base, la mesure de performance et l'analyse des seuils de performance pour divers packs d'administration dont SQL Server, IIS, Microsoft Windows® 2000 et Windows Server® 2003 Base Operating System. Vous pouvez activer, dans SMS 2003 Management Pack, la prise en charge de base de ces packs d'administration ou conserver les paramètres désactivés et activer les règles adéquates dans les autres packs d'administration.

  • Utilisez SQL Server Management Pack pour étendre l'analyse des serveurs de base de données du site et des points de gestion SMS dépendants de SQL Server.

  • Utilisez IIS Management Pack pour analyser les services Internet (IIS) aux niveaux des points de rapports, des points de gestion et des points de recherche de serveur. Ce pack d'administration peut également analyser les points de distribution sur lesquels le service de transfert intelligent en arrière-plan est activé.

  • Utilisez Microsoft Windows 2000 et Windows Server 2003 Base Operating System Management Pack pour analyser les composants de base Windows comme les statistiques d'utilisation du processeur, du disque et de la mémoire.

Il existe d'autres packs d'administration qui améliorent les capacités d'analyse de votre infrastructure SMS 2003, notamment Windows Network Load Balancing et Windows Active Directory®, pour lesquels SMS 2003 Management Pack ne fournit pas de règles.

  • Utilisez Windows Network Load Balancing Management Pack si, pour des raisons d'évolutivité, vous avez recours à l'équilibrage de la charge réseau afin d'assurer la prise en charge de plusieurs points de gestion de votre hiérarchie SMS.

  • Utilisez Windows Active Directory® Management Pack pour analyser le fonctionnement de votre infrastructure Active Directory.

Si vous déployez plusieurs packs d'administration dans votre environnement, il est possible que vous receviez des alertes redondantes dans la mesure où des règles identiques peuvent figurer dans plusieurs d'entre eux. Si vous désactivez les règles d'analyse redondantes, vous risquez d'affecter la précision des données de l'affichage d'état des packs d'administration que vous avez déployés. Trouvez le meilleur compromis entre la réception d'alertes redondantes et le bon fonctionnement de l'analyse d'état pour chaque pack d'administration déployé. Selon les packs d'administration supplémentaires déployés, examinez ces règles redondantes pour identifier celles que vous souhaitez activer dans votre environnement. Après l'installation de ces packs d'administration, vérifiez s'ils sont personnalisés et configurés comme il convient et si les règles adéquates sont activées pour chacun d'eux.

État d’exécution du programme de distribution de logiciels

Le client avancé SMS peut signaler des défaillances de programme via le pack d'administration.

Les administrateurs peuvent activer la case à cocher Générer une alerte MOM en cas d'échec de ce programme sous l'onglet Microsoft Operations Manager de la boîte de dialogue Propriétés du programme.

Procédure

Vous devez suivre la procédure décrite ci-après pour activer les alertes Microsoft Operations Manager 2007 en cas d'échec d'un programme SMS 2003.

Pour activer les alertes Microsoft Operations Manager 2007 pour un programme SMS 2003

  1. Dans la console SMS, accédez à Systems Management Server / Base de données du site - <nom du serveur de site> / Packages.

  2. Dans le volet d'informations, cliquez avec le bouton droit sur le programme, puis sélectionnez Propriétés. La boîte de dialogue des propriétés du programme s'ouvre.

  3. Cliquez sur l'onglet Microsoft Operations Manager.

  4. Activez la case à cocher Générer une alerte MOM en cas d'échec de ce programme. Cliquez sur OK.

Voir aussi

Concepts

Déploiement du SMS 2003 Management Pack

Autres ressources

Références du Microsoft Systems Management Server 2003 Management Pack


Déploiement du SMS 2003 Management Pack

Avant de déployer le Microsoft® Systems Management Server (SMS) 2003 Management Pack, consultez le guide de déploiement de Microsoft Operations Manager 2007 (éventuellement en anglais), disponible via la page Web Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259). Cette section fournit des instructions supplémentaires sur le déploiement des packs d’administration Operations Manager.

Pour déployer le SMS 2003 Management Pack, vous devez procéder comme suit :

  • Déployez l’Agent Operations Manager 2007 sur tous les ordinateurs dotés du composant serveur SMS.

Remarque
Si la carte de topologie ou le mode de maintenance d’Operations Manager 2007 est requis, vous devez déployer SMS 2003 SP3 avant d’importer le SMS 2003 Management Pack ou d’installer l’Agent Operations Manager 2007.

  • Importez le SMS 2003 Management Pack dans un groupe de configuration d’Operations Manager 2007.

  • Configurez les fournisseurs SMS et les serveurs de base de données de site SMS de manière à ce que les Agents Operations Manager 2007 puissent faire office de proxy pour les autres ordinateurs.

  • Menez à bien les tâches de test et de pilotage recommandées.

  • Menez à bien les tâches de paramétrage recommandées.

Dans cette section

Déploiement de l’Agent Operations Manager 2007

Test et pilotage du pack d'administration

Personnalisation du pack d’administration

Voir aussi

Concepts

Scénarios d'analyse du pack d'administration

Autres ressources

Présentation du Systems Management Server 2003 Management Pack
Exécution de tâches d'opération pour le SMS 2003 Management Pack
Dépannage du SMS 2003 Management Pack
Références du Microsoft Systems Management Server 2003 Management Pack


Déploiement de l’Agent Operations Manager 2007

L’Agent Operations Manager s’exécute sur chaque ordinateur surveillé par Operations Manager. Pour connaître les groupes d’ordinateurs surveillés par le SMS 2003 Management Pack, consultez la section Groupes d’ordinateurs pour SMS 2003 de ce guide. L’Agent Operations Manager 2007 collecte les données de surveillance sur l’ordinateur géré, applique des règles aux données collectées, puis envoie les données obtenues au serveur DCAM (Data Consolidator Agent Manager). La fonctionnalité de surveillance sur un ordinateur agent est fournie par le service Operations Manager 2007 (HealthService.exe), l’hôte Operations Manager 2007 (MonitoringHost.exe) et le compte d’action d’agent.

Pour déployer l’Agent Operations Manager 2007, vous pouvez utiliser l’Assistant Installation d’Operations Manager 2007 ou la distribution de logiciels SMS. Pour obtenir des détails sur le déploiement de l’Agent Operations Manager 2007 et sur l’utilisation de l’Assistant Installation d’Operations Manager 2007, consultez la section relative à la découverte d'ordinateurs et au déploiement d'Agents MOM dans le guide de déploiement de Microsoft Operations Manager 2007. Pour plus d’informations, consultez la page Web, éventuellement en anglais, relative à Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).

Remarque
Il est recommandé d’exécuter l’Agent Operations Manager 2007 sur les ordinateurs dotés du fournisseur SMS à l’aide du compte LocalSystem ou d’un compte dont les droits permettent d’accéder aux espaces de noms WMI SMS 2003 root, root\cimv2, root\sms, ainsi qu’à la clé de Registre SMS et aux sous-clés.

Pour déterminer si l’analyse sans agent peut être utilisée dans votre environnement, consultez, dans les Scénarios d'analyse du pack d'administration, la partie consacrée à la prise en charge de l’analyse sans agent.

Configuration des ordinateurs agents pour qu’ils s’exécutent dans les scénarios à faibles privilèges

La fonctionnalité de surveillance sur un ordinateur agent est fournie par le service Operations Manager 2007 (HealthService.exe), l’hôte Operations Manager 2007 (MonitoringHost.exe) et le compte d’action d’agent. Sous Microsoft Windows® 2000, le compte d’action doit être membre du groupe Administrateurs local. Sous Microsoft Windows™ 2003, vous pouvez, dans certaines circonstances, utiliser un compte à faibles privilèges pour le compte d’action de l’agent. Toutefois, pour que le compte d’action et le contexte utilisateur sous lesquels s’exécutent le service Operations Manager 2007 et l’hôte Operations Manager 2007 soient habilités à exécuter les fonctionnalités du SMS 2003 Management Pack, il est nécessaire de procéder à une configuration manuelle conséquente sur l’ordinateur agent. Sous Microsoft Windows Server™ 2003, le compte d’action d’agent doit disposer au minimum des autorisations et droits utilisateur suivants :

  • Membre du groupe Utilisateurs locaux

  • Accès aux journaux des événements Windows

  • Autorisation Gérer le journal d’audit et de la sécurité (SeSecurityPrivilege)

  • Autorisation Générer des audits de sécurité (SeAuditPrivilege)

  • Autorisation Permettre l’ouverture d'une session locale (SeInteractiveLogonRight)

Dans un scénario à faibles privilèges, le SMS 2003 Management Pack requiert que le compte utilisé pour le compte d’action d’agent possède des droits et des autorisations supplémentaires. Le tableau suivant détaille les droits d’accès devant être configurés manuellement.

Types d’accès requis par le SMS 2003 Management Pack

Ressource | Type d’accès | Instructions
Journal des événements Windows | Lire | Le compte d’action doit bénéficier du privilège Gérer le journal d’audit et de la sécurité, avec la stratégie locale ou globale.
Clés de Registre SMS | Lire | HKLM\Software\Microsoft\SMS Ajoutez le compte d’action aux propriétés de Registre et fournissez un accès en lecture hérité par toutes les sous-clés.
Clés de Registre des services Win32 | Lire | HKLM\System\CurrentControlSet\Services Ajoutez le compte d’action au groupe Utilisateurs locaux.
Fichiers temporaires générés par des scripts | Lire et Écrire | %Windir%\Temp Ajoutez le compte d’action au groupe Utilisateurs locaux. .
Fichiers journaux générés par des scripts | Lire et Écrire | %Windir%\Microsoft Operations Manager Ajoutez le compte d’action aux propriétés du dossier.
Fichiers journaux SMS | Lire | \SMS\Logs Ajoutez le compte d’action aux propriétés du dossier.
Espaces de noms WMI | Lire | root et root\cimv2 Aucune action n’est normalement requise.
Espaces de noms WMI | Lire | Aucune action n’est normalement requise.
Classes WMI SMS | Lire | SMS_Site SMS_R_System SMS_SystemResourceList SMS_SiteSystemSummarizer Ajoutez le compte d’action à la classe pour toutes les instances.
Droits de connexion de sécurité sur l’instance par défaut | Autoriser l’accès | Pour l’instance par défaut sur un ordinateur SQL Server géré, le compte d’action doit être autorisé à accéder aux connexions de sécurité. Dans SQL Server Enterprise Manager, ajoutez le compte d’action au nœud suivant : nom_instance\Security\Logins.
Accès à la base de données master sur l’instance par défaut (nécessaire pour identifier la base de données du site SMS) | Autoriser | Pour l’instance par défaut sur un ordinateur SQL Server géré, le compte d’action doit être autorisé à accéder à la base de données master. Dans SQL Server Enterprise Manager, ajoutez le compte d’action au nœud suivant : nom_instance\Databases\Master\Users. Conservez toutes les autorisations par défaut associées à ce nouvel utilisateur.
Accès à la base de données du site SMS sur l’instance par défaut | Autoriser | Pour l’instance par défaut sur un ordinateur SQL Server géré, le compte d’action doit être autorisé à accéder à la base de données du site SMS. Dans SQL Server Enterprise Manager, ajoutez le compte d’action au nœud suivant : nom_instance\Databases\<SMS site>\Users. Conservez toutes les autorisations par défaut associées à ce nouvel utilisateur.

Voir aussi

Concepts

Test et pilotage du pack d'administration
Personnalisation du pack d’administration

Autres ressources

Dépannage du SMS 2003 Management Pack
Problèmes connus liés à SMS 2003


Test et pilotage du pack d'administration

En complément des recommandations générales relatives au test des packs d’administration décrites dans le guide de déploiement de Microsoft Operations Manager 2007, cette section répertorie les tâches de test et de pilotage appropriées pour le SMS 2003 Management Pack. Pour plus d’informations, consultez la page Web, éventuellement en anglais, relative à Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).

Tâches de test

  • Vérifiez que les groupes d’ordinateurs SMS 2003 sont composés d’ordinateurs exécutant SMS 2003.

  • Après avoir activé les règles appropriées, vérifiez que les affichages et les rapports dans Operations Manager 2007 fonctionnent correctement. Cela englobe les affichages relatifs aux taux de traitement SMS et aux files d'attente SMS.

  • Par défaut, certaines règles liées aux autres packs d’administration, tels que l’IIS Management Pack et le SQL Server Management Pack, sont désactivées dans le SMS 2003 Management Pack. En fonction des packs d’administration supplémentaires que vous avez déployés, vous devez examiner ces règles désactivées afin d’identifier celles à éventuellement activer dans votre environnement.

  • Par défaut, toutes les règles de mesure des performances sont désactivées afin que soit réduit au minimum l’impact sur les ressources réseau, la mémoire et l’UC de l’agent. Vous pouvez activer ces règles afin d’approfondir la surveillance de l’agent.

  • Certains scripts SMS qui fonctionnent sur un ordinateur de fournisseur SMS ou sur un serveur de base de données de site SMS, ou bien qui accèdent à une base de données du site SMS, ne s’exécutent pas en mode sans agent. Vérifiez que tous les ordinateurs des groupes d’ordinateurs Fournisseur Microsoft SMS 2003 et Serveur de base de données de site Microsoft SMS sont configurés en tant qu’ordinateurs gérés par agent. En outre, étant donné que certains de ces scripts peuvent rediriger des événements via proxy, vérifiez que ces agents sont configurés de manière à autoriser la redirection par proxy.

Tâches de pilotage

  • Vérifiez que le déploiement ou la mise à niveau du SMS 2003 Management Pack depuis la version antérieure s’est correctement déroulé.

  • Vérifiez et modifiez les seuils personnalisés de votre environnement à l’aide de l’affichage Analyseur d'intégrité du seuil de performance.

  • Activez les règles de performance en plusieurs étapes pour évaluer l’impact de ces règles sur les performances d’Operations Manager 2007.

  • Vérifiez que les groupes d’ordinateurs SMS 2003 sont composés d’ordinateurs exécutant SMS 2003.

  • Après avoir activé les règles appropriées, vérifiez que les affichages et les rapports dans Operations Manager 2007 fonctionnent correctement. Cela englobe les affichages relatifs aux taux de traitement SMS, aux traitements des totaux et aux files d'attente SMS.

  • Par défaut, certaines règles relatives aux autres packs d’administration sont désactivées. En fonction des packs d’administration supplémentaires que vous avez déployés, vous devez examiner les règles désactivées afin d’identifier celles à éventuellement activer dans votre environnement.

  • Par défaut, certaines règles de performance sont désactivées afin que soit réduit au minimum l’impact sur les ressources réseau, la mémoire et l’UC de l’agent. Vous pouvez activer ces règles afin d’approfondir la surveillance de l’agent.

  • Vérifiez que des événements basés sur l’exécution de scripts SMS 2003 ne sont pas générés. En règle générale, ils révèlent des problèmes liés aux autorisations d’accès pour le script.

  • Vérifiez que le dimensionnement du serveur DCAM et de SQL Server est suffisant pour votre charge de production.

  • Vérifiez les processus des opérations et les contraintes liées au personnel.

  • Vérifiez que la pagination et la notification par messagerie fonctionnent correctement.

  • Vérifiez que les autorisations utilisées par Operations Manager 2007 lui permettent de fonctionner correctement, sans qu’elles soient pour autant excessives.

  • Si l’Agent Operations Manager 2007 n’est pas configuré de manière à s’exécuter sous le compte LocalSystem, vérifiez que les droits de sécurité minimum ont été satisfaits. Pour plus d’informations, consultez la partie « Configuration des ordinateurs agents pour qu’ils s’exécutent dans les scénarios à faibles privilèges », dans la section Déploiement de l’Agent Operations Manager 2007 de ce guide.

  • Vérifiez que les rôles Serveur SMS et Client SMS apparaissent dans l’affichage État. Cliquez sur un ordinateur qui héberge chacun de ces rôles, puis vérifiez que les composants sont visibles dans le volet de l’instance.

  • Vérifiez que les tâches de la console Administrateur SMS fonctionnent, en cliquant sur celles-ci. Si l’exécution de la tâche échoue, vérifiez que la console Administrateur SMS 2003 SP2 a été installée et que l’utilisateur connecté s’est déconnecté, puis s’est de nouveau connecté à la fin de l’installation de la console.

  • Dans l’affichage État, cliquez sur un serveur SMS et sur un client SMS pour vérifier que la page Rôles affiche le(s) rôle(s) approprié(s) et les données de propriété.

  • Dans le volet Analyse, accédez à Microsoft Systems Management Server (SMS) 2003, puis cliquez sur Diagramme de hiérarchie de site SMS 2003. Vérifiez qu’apparaissent tous les systèmes de site pour les sites dont le fournisseur SMS possède l’Agent Operations Manager 2007. Si un système de site n’apparaît pas, vérifiez la console Administrateur SMS afin de déterminer si le système de site a été découvert par le site et s’il apparaît dans la collection Tous les systèmes.

Une fois le test de pilotage achevé, exportez le SMS 2003 Management Pack afin de sauvegarder les modifications que vous avez apportées à celui-ci.

Voir aussi

Concepts

Personnalisation du pack d’administration
Déploiement de l’Agent Operations Manager 2007

Autres ressources

Dépannage du SMS 2003 Management Pack
Problèmes connus liés à SMS 2003


Personnalisation du pack d’administration

Afin d’optimiser la surveillance, vous pouvez personnaliser le SMS 2003 Management Pack en fonction des besoins de votre organisation. Si les règles existantes ne répondent pas aux besoins de votre organisation, modifiez-les ou créez de nouvelles règles.

Remarque Sauvegardez systématiquement le SMS 2003 Management Pack avant d’apporter des modifications. L’Assistant Exportation de pack d’administration d’Operations Manager 2007 vous permet de sauvegarder les packs d’administration ouverts.

La personnalisation peut inclure chacune des opérations suivantes :

  • activation et désactivation des règles à l’aide de remplacements ;

  • création de nouvelles règles ;

  • modification des critères d’alerte, de la gravité des alertes et de la suppression des alertes ;

  • définition de seuils personnalisés pour les règles. Toutes les règles de seuil de performance sont configurables. Si le seuil par défaut n’est pas optimal, vous pouvez recevoir des alertes superflues ou ne pas être alerté, en raison de la définition du seuil à un niveau trop élevé pour votre environnement ;

  • configuration du seuil des règles d’événement d’analyse des boîtes de réception et de l’intervalle d’interrogation à l’aide de remplacements ou, dans le cas de valeurs de seuil, en modifiant la vue XML ;

  • ajout de nouvelles règles d’événement d’analyse des boîtes de réception. Pour ajouter une nouvelle règle d’analyse des boîtes de réception, créez une nouvelle règle dans le pack d’administration par défaut, puis créez des remplacements pour les paramètres d’entrée de script (FileCountThreshold et InboxDirectoryName) et pour la planification ;

  • définition d’intervalles d’interrogation pour la mesure des performances, à l’aide de remplacements ;

  • ajout de contenu à la base de connaissances de la société ;

  • personnalisation des réponses aux alertes en modifiant les réponses aux règles, en en ajoutant de nouvelles ou en ajoutant des règles de traitement pour ces alertes ;

  • l’activation des règles de mesure des performances sur l’agent, sur le serveur exécutant Operations Manager 2007 et sur la base de données génère une quantité volumineuse de données et peut éventuellement nuire aux performances. Les règles de mesure des performances sont désactivées par défaut afin que vous puissiez décider si un impact potentiel sur les performances est acceptable. Examinez les règles de performance et activez ces règles par petits lots, afin que vous puissiez évaluer l’impact de ces règles sur les performances d’Operations Manager 2007, notamment sur la taille de la base de données ;

  • définition des paramètres des règles d’événement d’analyse des boîtes de réception et des règles connexes. Modifiez les deux scripts FileCountThreshold et InboxDirectoryName, en créant un remplacement ;

  • examen des règles afin de déterminer si elles sont applicables à votre environnement. Par défaut, certaines règles relatives aux autres packs d’administration sont désactivées. En fonction des packs d’administration supplémentaires que vous avez déployés, vous devez examiner les règles désactivées afin d’identifier celles à éventuellement activer dans votre environnement.

Pour plus d’informations sur la personnalisation des packs d’administration et sur leur exportation, consultez les rubriques relatives aux packs d'administration dans Operations Manager 2007 et à la façon d'exporter des personnalisations du pack d'administration dans l’aide d’Operations Manager 2007.

Analyse des boîtes de réception

L’Assistant Exportation d’Operations Manager 2007 vous permet d’enregistrer les changements apportés au pack d’administration par défaut avant d’effectuer de nouvelles modifications.

Configuration des règles d’analyse des boîtes de réception

Pour déployer ces règles sur les serveurs de sites centraux, principaux et secondaires, vous devez créer de nouvelles règles dans le pack d’administration, basées sur les règles du groupe Serveurs de site SMS - Commun. Ces règles peuvent ensuite être affectées au groupe de règles de traitement approprié pour le serveur de site ; modifiez le seuil, puis activez la règle.

  • Boîte de réception SMS 2003 : Analyse de la boîte de réception

  • Boîte de réception SMS 2003 : Contrôle l'erreur de script de la boîte de réception

  • Boîte de réception SMS 2003 : Seuil dépassé

La règle de traitement d’événement Boîte de réception SMS 2003 : Seuil dépassé surveille les événements déclenchés par le script SMS 2003 : Contrôle l'erreur de script de la boîte de réception. Une alerte unique est générée pour chaque boîte de réception dont le seuil dépasse la valeur de seuil spécifiée.

Dans le cas de ce script, la valeur de seuil par défaut correspond à 10 000 fichiers dans une boîte de réception. Vous pouvez créer un remplacement pour cette valeur dans le pack d’administration par défaut, pour ce paramètre de script comme pour tout autre. En cas de dépassement, un événement « Seuil dépassé » est déclenché. Vous pouvez modifier les paramètres de seuil en calculant la charge quotidienne prévue sur les serveurs pour chaque processus fonctionnant correctement, puis en ajoutant un pourcentage acceptable de mémoire tampon. Les règles d’analyse des boîtes de réception s’exécutent par défaut une fois par jour, par intervalle de quinze minutes à partir de 01:00. Pour réduire au minimum l’impact sur les performances, il est recommandé de conserver cet intervalle ou de le régler de manière à éviter autant que possible tout empiètement de l’exécution des scripts entre les règles d’analyse des boîtes de réception.

Le tableau suivant répertorie les règles d’analyse des boîtes de réception, les seuils par défaut et les boîtes de réception surveillées sous le fournisseur SMS Executive.

Analyse des boîtes de réception SMS Executive

Nom de la règle d’analyse de boîte de réception | Seuil par défaut | Nom de la boîte de réception
Boîte de réception SMS 2003 : Contrôle l'erreur de script de la boîte de réception | non applicable | non applicable
Boîte de réception SMS 2003 : Seuil dépassé | non applicable | non applicable
Boîte de réception SMS 2003 : Contrôle auth\dataldr.box | 10000 | Inboxes\auth\dataldr.box
Boîte de réception SMS 2003 : Contrôle auth\ddm.box | 10000 | Inboxes\auth\ddm.box
Boîte de réception SMS 2003 : Contrôle auth\sinv.box | 10000 | Inboxes\auth\sinv.box
Boîte de réception SMS 2003 : Contrôle compsumm.box\repl | 10000 | Inboxes\ compsumm.box\repl
Boîte de réception SMS 2003 : Contrôle dataldr.box | 10000 | Inboxes\ dataldr.box
Boîte de réception SMS 2003 : Contrôle ddm.box | 10000 | Inboxes\ ddm.box
Boîte de réception SMS 2003 : Contrôler despoolr.box\receive | 10000 | Inboxes\despoolr.box\receive
Boîte de réception SMS 2003 : Contrôler offermgr.box\INCOMING | 10000 | Inboxes\offermgr.box\INCOMING
Boîte de réception SMS 2003 : Contrôle offersum.box\repl | 10000 | Inboxes\ offersum.box\repl
Boîte de réception SMS 2003 : Contrôler replmgr.box\incoming | 10000 | Inboxes\replmgr.box\incoming
Boîte de réception SMS 2003 : Contrôle schedule.box\outboxes\LAN | 10000 | Inboxes\ schedule.box\outboxes\LAN
Boîte de réception SMS 2003 : Contrôle statmgr.box\statmsgs | 10000 | Inboxes\statmgr.box\statmsgs
Boîte de réception SMS 2003 : Contrôle swmproc.box\utilisation | 10000 | Inboxes\swmproc.box\usage

Procédure de remplacement des règles d’événement d’analyse des boîtes de réception

Préalablement au remplacement d’une règle d’événement d’analyse des boîtes de réception, le serveur de site Operations Manager 2007 doit découvrir les objets serveur de site SMS 2003 de type Serveurs de site Microsoft SMS 2003.

Pour remplacer les règles d’événement d’analyse des boîtes de réception

  1. Dans la console Opérateur d'Operations Manager 2007, cliquez sur le bouton Création.

  2. Accédez à Création / Objects du pack d'administration / Règles.

  3. Recherchez l'étendue Serveurs de site Microsoft SMS 2003.

  4. Cliquez avec le bouton droit sur une règle d’événement d’analyse de boîte de réception SMS 2003 appropriée, telle que Boîte de réception SMS 2003 : Contrôle schedule.box\requests, sélectionnez Remplacements, Remplacer la règle, puis cliquez sur Pour tous les objets de type : Serveurs de site Microsoft SMS 2003.

  5. Dans la zone Propriétés du remplacement, activez la case à cocher Enabled overide, puis définissez le Paramètre de remplacement sur True.

  6. Dans la zone Propriétés du remplacement, activez la case à cocher FileCountThreshold, puis attribuez au Paramètre de remplacement la valeur de seuil de votre choix.

  7. Cliquez sur OK. Cliquez sur OK. Les valeurs de seuil modifiées sont distribuées aux serveurs.

Procédure de modification de la surveillance du seuil du compteur de performance

Pour modifier la surveillance du seuil du compteur de performance, procédez comme suit :

Pour modifier la surveillance du seuil du compteur de performance

  1. Dans la console Opérateur d'Operations Manager 2007, cliquez sur le bouton Création.

  2. Accédez à Création / Objets du pack d'administration / Analyseurs.

  3. Appliquez l’étendue Serveur SMS.

  4. Accédez à SMS Server / Entity Health / MOM 2005 Computer Role Health, puis sélectionnez le rôle d’ordinateur approprié, tel que SS pour serveur de site.

  5. Double-cliquez sur la règle de contrôle des seuils de performances à modifier. La boîte de dialogue Performance Threshold Properties s’ouvre.

  6. Sélectionnez l’onglet Configuration.

  7. Cliquez sur Modifier. La boîte de dialogue Configuration XML s’ouvre.

  8. Dans le texte XML, modifiez la valeur de seuil concernée.

    • Définissez le paramètre <ValueExpression> imbriqué dans le paramètre <CriticalErrorExpression> pour modifier le seuil d’erreur critique.

    • Définissez le paramètre <ValueExpression> imbriqué dans le paramètre <WarningExpression> pour modifier le seuil d’avertissement.

  9. Cliquez sur OK. Cliquez sur OK. Les valeurs de seuil modifiées sont distribuées aux serveurs.

Voir aussi

Concepts

Test et pilotage du pack d'administration
Configuration de SMS prise en charge
Scénarios d'analyse du pack d'administration

Autres ressources

Dépannage du SMS 2003 Management Pack
Références du Microsoft Systems Management Server 2003 Management Pack


Exécution de tâches d'opération pour le SMS 2003 Management Pack

Il est recommandé de consulter et de résoudre rapidement toutes les alertes afin d'identifier celles de nature critique, avérée ou non. En outre, vous devez régulièrement effectuer d'autres tâches en fonction de votre environnement. En effet, de nombreux problèmes importants n'engendrent aucune alerte alors qu'ils nécessitent une attention régulière. Le Microsoft® Systems Management Server (SMS) 2003 Management Pack propose des vues et des rapports permettant de consulter les données dans le temps et fournissant des modèles qui indiquent les problèmes. Consultez les vues et les rapports afin de résoudre des problèmes avant qu'ils ne génèrent des alertes.

Vous devez effectuer les tâches quotidiennes, hebdomadaires et mensuelles indiquées dans cette section en adaptant leur fréquence d'exécution en fonction de votre environnement.

Dans cette section

Tâches quotidiennes SMS 2003

Tâches hebdomadaires pour SMS 2003

Tâches mensuelles pour SMS 2003

Tâches de la console Administrateur SMS 2003

Voir aussi

Concepts

Scénarios d'analyse du pack d'administration
Déploiement du SMS 2003 Management Pack

Autres ressources

Présentation du Systems Management Server 2003 Management Pack
Exécution de tâches d'opération pour le SMS 2003 Management Pack
Dépannage du SMS 2003 Management Pack
Références du Microsoft Systems Management Server 2003 Management Pack


Tâches quotidiennes SMS 2003

Il est recommandé d'effectuer quotidiennement les tâches ci-dessous :

  • Consulter toutes les alertes ouvertes.

  • Vérifier l'appartenance aux groupes d'ordinateurs

  • Vérifier que tous les Agents Operations Manager 2007 communiquent avec le serveur Operations Manager 2007.

  • Vérifier les files d'attente de performance.

  • Vérifier les taux de traitement de performance.

  • Vérifier la performance du serveur et des Agents Operations Manager 2007.

  • Vérifier l'appartenance aux groupes de notification ou les groupes de notification de règle de traitement d'événement.

  • Vérifier les sauvegardes du site SMS 2003.

  • Consulter les événements (facultatif).

Consulter toutes les alertes ouvertes

Dans le SMS 2003 Management Pack, les alertes s'affichent au format de description suivant :

$Computer$ <Rule Name>

$Description$

Event details

Consultez toutes les alertes générées dans Operations Manager 2007 afin de vous assurer de les traiter de manière opportune. Vous pouvez suivre l'une des méthodes ci-dessous pour consulter les alertes ouvertes :

  • Dans la console Opérateur, cliquez sur le bouton Analyse, développez Microsoft Systems Management Server (SMS) 2003, puis cliquez sur Alertes.

  • Dans la console Opérateur, cliquez sur le bouton Analyse, développez Microsoft Systems Management Server (SMS) 2003, puis cliquez sur Général. Sélectionnez Nouvelles alertes des dernières 72 heures.

  • Pour consulter les alertes par ordinateur ou par groupe d'ordinateurs, cliquez sur Ordinateurs et groupes. Pour afficher un récapitulatif par gravité d'alerte, cliquez avec le bouton droit sur le groupe d'ordinateurs SMS 2003 à examiner, cliquez sur Afficher, puis sur Alertes.

  • Il est possible de consulter les alertes dans la vue État, qui affiche la liste des ordinateurs et l'alerte de gravité la plus élevée. Double-cliquez sur un ordinateur pour consulter la liste des alertes actuelles correspondantes.

  • Il est possible de consulter les alertes dans la vue Diagramme. La vue Diagramme de la hiérarchie SMS 2003 affiche une représentation graphique de la hiérarchie SMS 2003. Chaque ordinateur contient une annotation d'état indiquant son alerte de gravité la plus élevée. Double-cliquez sur un ordinateur pour consulter la liste des alertes actuelles correspondantes.

Il est recommandé de consulter toutes les nouvelles alertes dans l'ordre suivant :

  1. Alertes du service principal SMS 2003

  2. Alertes du service associé SMS 2003

  3. Alertes de l'outil de synthèse d'état du système de site SMS 2003

  4. Alertes de l'état de santé des points de gestion SMS 2003

  5. Alertes des messages d'état SMS 2003

  6. Alertes des composants SMS 2003

  7. Alertes des files d'attente SMS 2003

  8. Alertes d'analyse de la boîte de réception SMS 2003

  9. Alertes d'échec de sauvegarde du site SMS 2003

  10. Alertes d'échec du programme SMS 2003

Vérifier l'appartenance aux groupes d'ordinateurs

Vous pouvez vérifier l'appartenance aux groupes d'ordinateurs à l'aide d'Operations Manager 2007.

  • Dans la console Opérateur, cliquez sur le bouton Création, cliquez sur Groupes, puis cliquez avec le bouton droit sur le groupe d'ordinateurs SMS 2003 de votre choix. Assurez-vous que chaque groupe d'ordinateurs affiché contient les ordinateurs appropriés.

Vérifier que les agents communiquent avec le serveur Operations Manager 2007

Les échecs de communication entre l'agent et l'infrastructure d'analyse vous empêchent de recevoir les alertes. Exécutez des rapports de disponibilité pour vous assurer que l'agent et le serveur qui exécute Operations Manager 2007 communiquent. Pour plus d'informations, voir la rubrique « Comment créer un rapport de disponibilité dans Operations Manager 2007 » dans l'aide Operations Manager 2007.

Vérifier les files d'attente et les taux de traitement de performance

Les files d'attente et les taux de traitement de performance s'avèrent très utiles dans le cadre de la détection des tendances quotidiennes et de la détermination de l'état de la hiérarchie SMS. Vous pouvez consulter les files d'attente et les taux de traitement de performance dans Operations Manager 2007.

Pour vérifier les files d'attente de performance

Pour vérifier les files d'attente de performance, suivez la procédure ci-dessous :

Pour vérifier les files d'attente de performance

  1. Dans la console Opérateur, cliquez sur le bouton Analyse, puis développez Microsoft Systems Management Server (SMS) 2003.

  2. Développez Performance, puis Files d'attente. Ensuite, cliquez sur le sous-dossier de composants de votre choix. À l'aide de l'option de compteur, réduisez les données affichées, diminuez le nombre d'ordinateurs ou sélectionnez uniquement les ordinateurs qui vous intéressent.

Pour vérifier les taux de traitement de performance

Pour vérifier les taux de traitement de performance, suivez la procédure ci-dessous :

Pour vérifier les taux de traitement de performance

  1. Dans la console Opérateur, cliquez sur le bouton Analyse, puis développez Microsoft Systems Management Server (SMS) 2003.

  2. Développez Performance, puis Files d'attente. Ensuite, cliquez sur le sous-dossier de composants de votre choix. À l'aide de l'option de compteur, réduisez les données affichées, diminuez le nombre d'ordinateurs ou sélectionnez uniquement les ordinateurs qui vous intéressent.

Analyse des sauvegardes du site SMS 2003

Activez la tâche de maintenance des sauvegardes du site SMS et planifiez les sauvegardes conformément à l'environnement de votre entreprise. Une fois démarré, le service de sauvegarde du site SMS arrête d'abord tous les services SMS, notamment SMS_EXECUTIVE, SMS_SQL_MONITOR et SMS_SITE_COMPONENT_MANAGER. Il n'accepte pas les sauvegardes d'exécution lors des opérations suivantes :

  • Copie de portions du dossier d'installation SMS vers le chemin d'exportation de sauvegarde.

  • Sauvegarde des différentes valeurs du Registre SMS.

  • Sauvegarde de la base de données du site SMS sur un serveur exécutant Microsoft SQL Server™.

Une fois la sauvegarde terminée, le service de sauvegarde du site SMS redémarre les services SMS. L'arrêt et le redémarrage de ces services sont normaux lors de la sauvegarde et ne constituent aucune erreur critique. Les alertes attendues de ces arrêts de services sont supprimées lors de la sauvegarde du site SMS. Vous pouvez corréler ces arrêts et redémarrages de service, ainsi que les arrêts et redémarrages de la sauvegarde du site SMS. Pour cela, vous devez activer les règles ci-dessous, qui génèrent des alertes d'information lors du démarrage ou de l'arrêt du service de sauvegarde du site SMS :

  • Arrêt du service SMS 2003 exécutant : SMS_SITE_BACKUP

  • Démarrage du service SMS 2003 exécutant : SMS_SITE_BACKUP

Les alertes ci-dessous sont générées en cas d'échec de démarrage ou d'arrêt inattendu du service de sauvegarde du site SMS :

  • Échec du service SMS 2003 : arrêt inattendu de SMS_SITE_BACKUP

  • Échec du service SMS 2003 : SMS_SITE_BACKUP a été suspendu au démarrage

  • Échec du service SMS 2003 : SMS_SITE_BACKUP n'a pas pu démarrer

  • Échec du service SMS 2003 : SMS_SITE_BACKUP n'a pas pu se connecter

  • Échec du service SMS 2003 : SMS_SITE_BACKUP dépend d'un autre service qui n'a pas pu démarrer ou qui n'existe pas

Si une alerte indique que le service a été interrompu de manière inattendue, assurez-vous que tous les services arrêtés ont été redémarrés. En effet, le service de sauvegarde du site SMS peut avoir été interrompu avant le redémarrage de ces services.

Les alertes de message d'état ci-dessous sont générées pour indiquer la réussite ou l'échec de la sauvegarde :

  • État de SMS 2003 : la sauvegarde du site s'est correctement effectuée

  • État de SMS 2003 : la sauvegarde du site a échoué

La sauvegarde peut échouer en raison de problèmes d'accès, d'une insuffisance d'espace disque, d'un échec de démarrage ou d'arrêt de services ou d'un échec d'opérations SQL Server.

Consulter les événements

Consultez régulièrement les événements, car ils indiquent les échecs non critiques et permettent de connaître l'état de fonctionnement de l'Agent Operations Manager 2007.

Pour consulter les événements

Pour consulter les événements, suivez la procédure ci-dessous :

Pour consulter les événements

  1. Dans la console Opérateur, cliquez sur le bouton Analyse.

  2. Développez Microsoft Systems Management Server (SMS) 2003, puis cliquez sur Événements.

Voir aussi

Concepts

Tâches hebdomadaires pour SMS 2003
Tâches mensuelles pour SMS 2003
Tâches de la console Administrateur SMS 2003

Autres ressources

Exécution de tâches d'opération pour le SMS 2003 Management Pack
Dépannage du SMS 2003 Management Pack
Références du Microsoft Systems Management Server 2003 Management Pack


Tâches hebdomadaires pour SMS 2003

En plus des tâches effectuées quotidiennement, effectuez chaque semaine les tâches suivantes :

  • Consultez les rapports. Pour obtenir la liste des rapports fournis dans SMS 2003 Management Pack, voir la section Rapports SMS 2003 de ce guide.

  • Examinez les alertes, les événements et les performances pour la semaine écoulée afin d'identifier les problèmes potentiels et les tendances.

  • Le cas échéant, ajustez les paramètres de configuration de MOM 2007, par exemple l'intervalle des pulsations de l'Agent MOM 2007, l'intervalle de vérification du statut d'analyse de services, l'intervalle de vérification des pulsations par Agent Manager, les intervalles de découverte et les paramètres de nettoyage de base de données.

  • Consultez l'historique des sauvegardes des sites SMS.

  • Examinez l'historique des sauvegardes du groupe de configuration MOM 2007 pour SMS 2003.

  • Vérifiez le journal et la base de données SQL Server.

  • Exécutez les rapports de disponibilité SMS 2003 pour déterminer la disponibilité des serveurs SMS et de leurs composants.

  • Vérifiez votre hiérarchie SMS dans le diagramme Hiérarchie SMS 2003.

Voir aussi

Concepts

Tâches quotidiennes SMS 2003
Tâches mensuelles pour SMS 2003
Tâches de la console Administrateur SMS 2003

Autres ressources

Exécution de tâches d'opération pour le SMS 2003 Management Pack
Dépannage du SMS 2003 Management Pack
Références du Microsoft Systems Management Server 2003 Management Pack


Tâches mensuelles pour SMS 2003

En plus des tâches quotidiennes et hebdomadaires, examinez chaque mois les données appartenant aux catégories suivantes :

Alertes et événements les plus courants

  • Alertes les plus courantes

  • Événements les plus courants

  • Alertes et événements les plus courants par groupe de règles

  • Alertes et événements les plus courants par composant SMS 2003

  • Alertes et événements les plus courants par fonctionnalité SMS 2003

Élaborez un plan d'action pour réduire leur nombre.

Analyse des retards de traitement SMS

  • Examinez les rapports concernant les tendances des retards de traitement sur les divers systèmes de site.

Tendances des retards de traitement SMS

  • Examinez les rapports sur les retards de traitement pour vous assurer qu'il n'existe pas à long terme une tendance à la hausse du nombre de retards de traitement ou un niveau inacceptable de retards affectant les contrats de niveau de service (SLA) sur un système de site SMS.

Tendances des performances SMS : totaux et taux de traitement

  • Enregistrements de données de découverte

  • Inventaire matériel

  • Inventaire logiciel

  • Contrôle de logiciel

  • Messages d'état

Performances générales du système

  • Utilisation du disque

  • Utilisation de la mémoire

  • Utilisation du processeur

Disponibilité des services SMS

  • SMS_EXECUTIVE

  • Service hôte de l'agent SMS

  • Service client SMS

  • SMS_REPORTING_POINT

  • SMS_SERVER_LOCATOR_POINT

  • SMS_SQL_MONITOR

  • SMS_SITE_COMPONENT_MANAGER

Disponibilité de SMS

  • Exécutez les rapports de disponibilité SMS 2003 pour déterminer la disponibilité des serveurs et composants SMS.

Voir aussi

Concepts

Tâches quotidiennes SMS 2003
Tâches hebdomadaires pour SMS 2003
Tâches de la console Administrateur SMS 2003

Autres ressources

Exécution de tâches d'opération pour le SMS 2003 Management Pack
Dépannage du SMS 2003 Management Pack
Références du Microsoft Systems Management Server 2003 Management Pack


Tâches de la console Administrateur SMS 2003

Pour pouvoir exécuter les tâches de la console Administrateur SMS, la console Administrateur de Microsoft Systems Management Server (SMS) 2003 SP2 ou version ultérieure doit être installée sur le même ordinateur que la console Opérateur d'Operations Manager 2007. Une fois la console Administrateur SMS installée, vous devez fermer votre session Windows, puis la rouvrir afin d'activer la fonctionnalité des tâches.

Tâches du pack d'administration

Tâche | Description
Console Administrateur SMS | Ouvre la console Administrateur SMS sur l'ordinateur sélectionné. Cette tâche concerne les ordinateurs qui hébergent le rôle de serveur du site SMS.
Tous les messages d'état SMS | Recherche le serveur de site de l'ordinateur, ouvre une fenêtre MMC et exécute une requête sur les messages d'état afin de renvoyer tous les messages d'état associés à l'ordinateur sélectionné. Cette tâche concerne tous les systèmes.
Gestionnaire de service SMS | Ouvre le Gestionnaire de service SMS sur l'ordinateur sélectionné. Cette tâche concerne les ordinateurs qui hébergent le rôle de serveur du site SMS.
Explorateur de ressources SMS | Recherche le serveur de site de l'ordinateur, ouvre une fenêtre MMC affichant l'Explorateur de ressources SMS et contenant les données de l'ordinateur sélectionné. Cette tâche concerne tous les systèmes.

Voir aussi

Concepts

Tâches quotidiennes SMS 2003
Tâches hebdomadaires pour SMS 2003
Tâches mensuelles pour SMS 2003

Autres ressources

Exécution de tâches d'opération pour le SMS 2003 Management Pack
Dépannage du SMS 2003 Management Pack
Références du Microsoft Systems Management Server 2003 Management Pack


Dépannage du SMS 2003 Management Pack

Vous pouvez effectuer une série d’opérations pour résoudre les problèmes liés au produit :

  • Vérifiez qu’Operations Manager 2007 est correctement installé.

  • Vérifiez que les paramètres de configuration d’Operations Manager 2007 sont correctement définis.

  • Vérifiez que tous les systèmes Microsoft® Systems Management Server (SMS) ont été configurés avec les informations MOM.

  • Vérifiez que tous les ordinateurs de base de données du site SMS et de fournisseur SMS gérés sont équipés de l’Agent Operations Manager 2007 et qu’ils sont en mesure de faire office de proxy pour les autres ordinateurs.

  • Vérifiez que l’importation du pack d’administration est achevée et qu’elle s’est correctement déroulée.

  • Vérifiez que toutes les entités appropriées sont activées, telles que les règles et les alertes associées.

  • Vérifiez que les groupes d’ordinateurs sont composés des ordinateurs adéquats. Vous pouvez utiliser les affichages pour effectuer cette inspection.

  • Vérifiez l’absence d’alerte relative à un échec lié aux pulsations.

  • Vérifiez que l’intervalle de pulsation est correctement défini et que les règles sont propagées à l’ordinateur de l'Agent Operations Manager 2007.

  • Vérifiez que les services associés, notamment le service Infrastructure de gestion Windows (WMI), le service de publication sur le Web, le service d’administration IIS (Internet Information Services), le service BITS (Background Intelligent Transfer Service) et MSSQLServer, sont installés et correctement exécutés sur les systèmes de site SMS 2003.

  • Vérifiez qu’aucune règle n’est automatiquement désactivée par Operations Manager 2007 en raison d’une activation excessive, d’une syntaxe incorrecte ou d’une exécution de scripts de trop longue durée.

  • Vérifiez que tous les compteurs de performance sont correctement installés.

Dans cette section

Problèmes connus liés à SMS 2003

Voir aussi

Concepts

Scénarios d'analyse du pack d'administration
Déploiement du SMS 2003 Management Pack

Autres ressources

Présentation du Systems Management Server 2003 Management Pack
Exécution de tâches d'opération pour le SMS 2003 Management Pack
Références du Microsoft Systems Management Server 2003 Management Pack


Problèmes connus liés à SMS 2003

Vous trouverez ci-dessous les problèmes connus liés au Systems Management Server 2003 Management Pack pour Operations Manager 2007.

Le mode de maintenance et la vue Topologie nécessitent SMS 2003 SP3

SMS peut perturber l'installation d'un logiciel non-Microsoft qui arrête le service WMI

Analyse WMI

Les tâches SMS ne peuvent être exécutées que dans le contexte utilisateur utilisé pour installer la console Administrateur SMS 2003

Le SMS 2003 Management Pack ne peut pas détecter le site SMS secondaire si la console Administrateur SMS est installée sur le même ordinateur

Redémarrage du système

Script Monitor SMS Status Messages dans SMS 2003

Le script Monitor Site Summarizer dans SMS 2003 est décalé par rapport à la fréquence de l'outil de synthèse de l'état du système de site par défaut

Les règles de messages d'état qui analysent la connectivité de l'expéditeur sont dépendantes de l'état de fonctionnement de l'expéditeur

Analyse BITS désactivée par défaut

Le chemin du fournisseur d'application est défini par défaut sur C:\SMS\Logs et n'est peut-être pas valide sur tous les serveurs de site SMS

Le mode de maintenance et la vue Topologie nécessitent SMS 2003 SP3

SMS 2003 SP3 est requis sur les serveurs de site SMS 2003 afin d'activer le mode de maintenance et d'afficher la topologie du site à l'aide d'Operations Manager 2007. Pour plus d'informations, voir Configuration de SMS prise en charge.

SMS peut perturber l'installation d'un logiciel non-Microsoft qui arrête le service WMI

Le SMS 2003 Management Pack peut perturber l'installation d'un logiciel non-Microsoft qui accède au service WMI. En effet, la plupart des scripts du pack d'administration peuvent redémarrer le service WMI, car ils utilisent WMI pour accéder au Registre. Si le service WMI est activé et peut être démarré, Component Object Model (COM) redémarre WMI.

Lors de l'installation ou de la mise à niveau d'un logiciel non-Microsoft, si WMI s'arrête sans être désactivé, le redémarrage automatique du script WMI risque de faire échouer l'installation du logiciel non-Microsoft. Cela peut poser un problème pour la mise à niveau de WMI ou du fournisseur WMI si le programme d'installation ne désactive pas d'abord le service WMI. Ce problème concerne tous les clients de WMI.

Analyse WMI

  • Basées sur l'événement système Windows NT®, les règles ci-dessous consignent les événements du Gestionnaire de contrôle des services en cas d'échec de service inattendu. Il n'existe aucune restriction de système d'exploitation connue liée à ces règles.

  • Échec du service associé SMS 2003 : arrêt inattendu de l'infrastructure de gestion Windows (WMI, Windows Management Instrumentation).

  • Échec du service associé SMS 2003 : l'infrastructure WMI a été suspendue au démarrage.

  • Échec du service associé SMS 2003 : l'infrastructure WMI n'a pas pu démarrer.

  • Échec du service associé SMS 2003 : l'infrastructure WMI n'a pas pu se connecter.

  • Échec du service associé SMS 2003 : l'infrastructure WMI dépend d'un autre service qui n'a pas pu démarrer ou qui n'existe pas.

Les tâches SMS ne peuvent être exécutées que dans le contexte utilisateur utilisé pour installer la console Administrateur SMS 2003

Ce problème se présente car la variable d'environnement SMS_UI_PATH a été créée par l'installation de la console Administrateur SMS en tant que variable d'environnement utilisateur, et non comme variable d'environnement système. Pour contourner ce problème, copiez le nom et la valeur de la variable SMS_UI_PATH, puis définissez les variables ci-dessus en tant que variables d'environnement système. Ainsi, tous les opérateurs et administrateurs pourront appeler des tâches sans générer d'erreurs.

Le Systems Management Server 2003 Management Pack ne peut pas détecter le site SMS secondaire si la console Administrateur SMS est installée sur le même ordinateur

Si la console Administrateur Systems Management Server 2003 est installée sur un ordinateur qui fait également office de serveur de site secondaire SMS, le SMS 2003 Management Pack ne peut pas identifier le serveur comme tel.

Pour contourner ce problème, lors de l'installation de la console Administrateur SMS sur un serveur de site secondaire SMS, remplacez la valeur 4 de la clé de Registre HKLM\SOFTWARE\Microsoft\SMS\Setup\Type par la valeur 2.

Redémarrage du système

En cas de redémarrage du système, vous pouvez recevoir uniquement quelques alertes d'arrêt de service, mais aucun événement ni aucune alerte signalant que le système a redémarré. Pour détecter un arrêt attendu ou inattendu du système, la meilleure solution est d'installer le Microsoft Windows Server Base Operating System Management Pack, qui contient une règle vous prévenant en cas de redémarrage du système. D'autres méthodes permettant de déterminer si un redémarrage système a eu lieu consistent à vérifier si les journaux SMS, le journal des événements Operations Manager 2007 NT, les journaux des événements Windows NT et les événements Operations Manager 2007 font état de communications de la part des agents.

Script Monitor SMS Status Messages dans SMS 2003

Lorsque la taille de la table des messages d'état SMS atteint 4 294 967 296 messages, l'ID d'enregistrement est remis à zéro. Dans SMS 2003, le script Monitor SMS Status Messages ne permet pas de détecter le moment auquel l'ID d'enregistrement a été remis à zéro. En effet, à l'heure actuelle, ce script n'effectue une recherche qu'à partir de l'ID d'enregistrement du dernier message d'état traité. Si l'ID d'enregistrement est remis à zéro, le pack d'administration ne peut pas détecter les nouveaux messages d'état.

Sur le serveur de site, notez la valeur de l'ID d'enregistrement du message d'état suivant dans la clé de Registre HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER. Il s'agit de l'ID d'enregistrement suivant placé dans la table SQL StatusMessages. Si cette valeur est inférieure à la valeur LastRecordID, la table StatusMessages est revenue au début. Le script ne traite plus de messages tant que la valeur de l'ID d'enregistrement du message d'état suivant reste inférieure à la valeur LastRecordID définie dans le fichier VarSet.

Vous devez régulièrement analyser la clé de Registre HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER sur le serveur de site afin de connaître l'ID d'enregistrement du message d'état suivant. Pour les petites organisations ou les sites de petite taille situés dans le bas de la hiérarchie SMS, il est recommandé de contrôler cette clé de Registre tous les deux ou trois mois. Quant aux grandes organisations ou aux sites comportant plusieurs sites enfants, il est recommandé de la contrôler tous les mois. Si la valeur se rapproche de 4 294 967 296, analysez-la plus fréquemment. Une fois l'ID d'enregistrement remis à zéro, vous devez débloquer l'analyse des messages d'état sur l'ordinateur qui exécute le serveur de base de données du site SMS. Vous indiquez l'emplacement de la base de données du site SMS lors de l'installation de SMS.

Pour automatiser l'analyse de la clé de Registre, il est possible de créer un attribut d'ordinateur et un groupe d'ordinateurs afin d'analyser les ordinateurs dont la valeur s'approche de ce seuil.

Pour localiser toutes les bases de données du site SMS dans votre groupe de configuration

  1. Dans la console Opérateur, cliquez sur le bouton Création.

  2. Dans le volet des résultats, cliquez avec le bouton droit sur Microsoft Systems Management Server (SMS) 2003, puis cliquez sur Afficher les membres du groupe.

Pour débloquer l'analyse des messages d'état

  1. Sur l'ordinateur qui héberge le rôle de base de données du site SMS, dans le dossier Temp de Windows, ouvrez le fichier texte suivant : SMS 2003 Monitor SMS Status Messages.VarSet. L'entrée LastRecordID_[Nom_base_données_SMS] correspond à un ID d'enregistrement qui indique le dernier message d'état traité par le script dans la table SQL StatusMessages.

  2. Sur l'ordinateur qui héberge le rôle de base de données du site SMS, dans le fichier SMS 2003 Monitor SMS Status Messages.VarSet, modifiez la valeur LastRecordID_[Nom_base_données_SMS] du site approprié afin qu'elle corresponde à l'ID d'enregistrement du message d'état suivant, moins un. Si vous obtenez une valeur de 4 294 967 296, définissez la valeur sur zéro, puis enregistrez le fichier.

Le script Monitor Site Summarizer dans SMS 2003 est décalé par rapport à la fréquence de l'outil de synthèse de l'état du système de site par défaut

La fréquence d'exécution du script Monitor Site System Summarizer dans SMS 2003 est décalée de 10 minutes par rapport à la fréquence d'interrogation de l'outil d'une heure. La console Administrateur SMS permet de configurer la planification de l'outil de synthèse d'état du système de site. Toutefois, elle ne modifie pas la fréquence d'interrogation, mais uniquement la fréquence des autres tâches de maintenance. Dans SMS 2003, le script Monitor Site System Summarizer est exécuté par un fournisseur d'événement chronométré, Planifiez toutes les 60 minutes, synchronisez à 00:10. Le décalage de 10 minutes permet à l'outil de synthèse de l'état du système de site de terminer son cycle. Si cette période est insuffisante, prolongez-la. À défaut, le script se termine avant que l'outil n'ait pu terminé son cycle, ce qui entraîne la signalisation d'un ancien état du système de site.

Les règles de messages d'état qui analysent la connectivité de l'expéditeur sont dépendantes de l'état de fonctionnement de l'expéditeur

Si l'expéditeur ne peut pas se connecter au site parent, les messages d'état ne remontent pas la hiérarchie SMS et le pack d'administration ne génère pas d'alerte relative à ces messages d'état. Cette situation s'applique plus particulièrement aux sites secondaires, dont le script SMS 2003 Monitor Status Message n'est pas exécuté. Les règles de messages d'état ci-dessous qui analysent la connectivité de l'expéditeur sont dépendantes de l'état de fonctionnement de l'expéditeur et sont désactivées par défaut :

  • État de SMS 2003 : L'expéditeur ne peut pas se connecter au site distant via le réseau local (sécurité standard).

  • État de SMS 2003 : L'expéditeur ne peut pas se connecter au site via RAS.

  • État de SMS 2003 : L'expéditeur ne peut pas se connecter au site distant via le réseau local (sécurité avancée).

Remarque
Toutes ces règles sont désactivées par défaut. Pour qu'elles puissent fonctionner, chaque serveur de base de données du site SMS (ou au moins le site central) doit être un ordinateur géré.

Une méthode d'analyse parallèle est fournie en fonction du fournisseur du journal d'application : le journal de l'expéditeur SMS 2003. Ces règles sont activées par défaut. Si vous les désactivez, envisagez d'activer les règles de message d'état compagnon ci-dessus. N'activez pas simultanément les deux ensembles de règles sous peine de générer des alertes en double. En ce qui concerne ces événements ou ces règles d'alerte, aucune consolidation ne porte sur le message d'état et sur la règle de composant active.

  • Composant SMS 2003 : L'expéditeur ne peut pas se connecter au site distant via le réseau local (sécurité standard).

  • Composant SMS 2003 : L'expéditeur ne peut pas se connecter au site via RAS.

  • Composant SMS 2003 : L'expéditeur ne peut pas se connecter au site distant via le réseau local (sécurité avancée).

Pour que ces règles puissent fonctionner, vous devez les modifier afin qu'elles pointent vers les fichiers journaux SMS. En outre, chaque serveur SMS lié à un expéditeur doit être un ordinateur géré.

Analyse BITS désactivée par défaut

Le service BITS (Background Intelligent Transfer Service) étant démarré à la demande par le client avancé SMS, la règle ci-dessous est désactivée par défaut dans le SMS 2003 Management Pack :

  • Service associé SMS 2003 exécutant : service BITS (Background Intelligent Transfer Service)

Désactivez cette règle si le service est configuré pour démarrer automatiquement.

Les règles ci-dessous sont activées par défaut afin de pouvoir analyser les problèmes liés au service BITS et de signaler si l'hôte de l'agent SMS ne parvient pas à démarrer le service BITS :

  • Échec du service SMS 2003 : Arrêt inattendu du service BITS (Background Intelligent Transfer Service).

  • Échec du service SMS 2003 : Le service BITS (Background Intelligent Transfer Service) a été suspendu au démarrage.

  • Échec du service SMS 2003 : Échec de démarrage du service BITS (Background Intelligent Transfer Service).

  • Échec du service SMS 2003 : Le service BITS (Background Intelligent Transfer Service) n'a pas pu se connecter.

Échec du service SMS 2003 : Le service BITS (Background Intelligent Transfer Service) dépend d'un autre service qui n'a pas pu démarrer ou qui n'existe pas.

Le chemin du fournisseur d'application est défini par défaut sur C:\SMS\Logs et n'est peut-être pas valide sur tous les serveurs de site SMS

Quatre règles de composant utilisent le fournisseur du journal d'application pour analyser les fichiers journaux SMS dans C:\SMS\Logs :

  • Composant SMS 2003 : L'expéditeur ne peut pas se connecter au site distant via le réseau local (sécurité standard).

  • Composant SMS 2003 : L'expéditeur ne peut pas se connecter au site via RAS.

  • Composant SMS 2003 : L'expéditeur ne peut pas se connecter au site distant via le réseau local (sécurité avancée).

  • Composant SMS 2003 : Le Gestionnaire de distribution n'a pas pu traiter un package.

Les règles d'expéditeur sont activées par défaut, tandis que le Gestionnaire de distribution est désactivé par défaut. Si vous avez installé SMS sur un autre lecteur que C ou si avez modifié le dossier par défaut des journaux, vous devez modifier cette règle avant de l'activer. Si cette règle ne pointe pas vers le dossier de fichiers journaux approprié, l'alerte ne renvoie pas les informations demandées.

Lorsque vous modifiez la règle afin d'indiquer le chemin correct, vous pouvez saisir le chemin des fichiers journaux ou créer une variable d'environnement et modifier la règle pour qu'elle utilise cette variable. Si vous saisissez un chemin, celui-ci doit être accessible par tous les serveurs de site concernés par cette règle. Si vous disposez de deux chemins différents (un pour les serveurs de site principaux et un second pour les serveurs de site secondaires), suivez la procédure ci-dessous :

Pour modifier le code XML des règles de composant afin d'utiliser un autre chemin de fichiers journaux

  1. Dans la console Opérateur d'Operations Manager 2007, cliquez sur le bouton Création, développez Objets du pack d'administration, puis cliquez sur Règles.

  2. Dans le volet Détails, cliquez avec le bouton droit sur la règle à modifier, puis cliquez sur Propriétés.

  3. Cliquez sur l'onglet Configuration.

  4. Dans le volet Réponses, sélectionnez la réponse dont vous souhaitez modifier le code XML.

  5. Cliquez sur le bouton Modifier. La boîte de dialogue Génère une alerte - Propriétés s'affiche alors.

  6. Dans l'onglet Configuration de la boîte de dialogue Génère une alerte - Propriétés, cliquez sur le bouton Modifier.

  7. Modifiez la chaîne de répertoire à votre convenance. Cliquez sur OK, sur Appliquer, puis sur OK pour enregistrer la modification apportée.

Voir aussi

Concepts

Configuration de SMS prise en charge

Autres ressources

Dépannage du SMS 2003 Management Pack
Présentation du Systems Management Server 2003 Management Pack
Références du Microsoft Systems Management Server 2003 Management Pack


Références du Microsoft Systems Management Server 2003 Management Pack

Ces matériaux de référence donnent des conseils sur Operations Manager 2007 et sur Systems Management Server 2003

Dans cette section

Ressources supplémentaires pour le Microsoft Systems Management Server 2003 Management Pack

Sites et composants du SMS 2003 Management Pack

Groupes d’ordinateurs pour SMS 2003

Groupes de règles SMS 2003

Fournisseurs de SMS 2003

Scripts pour SMS 2003

Affichages Microsoft SMS 2003

Diagrammes SMS 2003

Rapports SMS 2003

Voir aussi

Concepts

Scénarios d'analyse du pack d'administration
Déploiement du SMS 2003 Management Pack

Autres ressources

Présentation du Systems Management Server 2003 Management Pack
Exécution de tâches d'opération pour le SMS 2003 Management Pack
Dépannage du SMS 2003 Management Pack


Ressources supplémentaires pour le Microsoft Systems Management Server 2003 Management Pack

Les ressources suivantes sont disponibles pour le Microsoft Systems Management Server 2003 Management Pack.

Microsoft Operations Manager 2007

Pour accéder à la documentation principale du produit Microsoft Operations Manager 2007 sur Internet, ainsi que pour obtenir les informations les plus récentes au sujet de System Center Operations Manager 2007, consultez la page Web, éventuellement en anglais, relative au produit Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).

SMS 2003

La documentation principale du produit, l’aide de la console Administrateur SMS, le glossaire SMS et la bibliothèque en ligne SMS contiennent toutes les informations nécessaires au déploiement et à l'utilisation de SMS 2003. La bibliothèque en ligne SMS et l’aide de la console Administrateur SMS sont accessibles à partir de la console Administrateur SMS.

Bibliothèque en ligne SMS 2003

La bibliothèque en ligne SMS fournit des pointeurs vers toutes les informations nécessaires au déploiement et à l'utilisation de SMS. Vous pouvez exécuter la bibliothèque en ligne SMS de deux façons après avoir installé SMS 2003 :

  • Dans le menu Démarrer, cliquez sur Programmes, puis sur Systems Management Server et sélectionnez Bibliothèque en ligne SMS.

  • Dans l'arborescence de la console Administrateur SMS, cliquez avec le bouton droit sur Bibliothèque en ligne SMS, puis cliquez sur Bibliothèque en ligne d'exécution.

La bibliothèque en ligne comprend les éléments suivants :

  • « Notes de mise à jour de SMS 2003 », qui contiennent des informations essentielles sur SMS

  • « Nouveautés dans cette version de SMS », qui compare cette version de SMS 2003 aux versions antérieures

  • Un lien vers la page Web de la documentation du produit SMS

  • Des liens vers les pages de téléchargement du SMS 2003 Device Management Feature Pack et du SMS 2003 Operating System Deployment Feature Pack

SMS sur le Web

  • Pour rechercher les livres blancs et les informations sur les produits connexes, consultez le site Web du produit Microsoft Systems Management Server 2003 (éventuellement en anglais). En outre, le site Web de SMS fournit des informations spécifiques sur l’utilisation de SMS avec d’autres produits Microsoft, tels que Microsoft Windows® XP et Microsoft Office XP.

  • La page Web relative à la documentation du produit Systems Management Server 2003 (éventuellement en anglais) propose des liens vers des versions consultables et téléchargeables de la documentation principale du produit SMS 2003.

  • Microsoft gère de nombreux groupes de discussion libres d’accès dans lesquels vous pouvez publier vos questions et obtenir gratuitement une aide de la part d’autres utilisateurs et, souvent, des membres de l’équipe du produit SMS. Pour plus d’informations sur les groupes de discussion gratuits, visitez la page relative à la communauté Web Systems Management Server (éventuellement en anglais).

  • La page Web relative au support de Systems Management Server (éventuellement en anglais) met à votre disposition de nombreuses sources d’informations, telles que des articles sur des procédures techniques, des FAQ, des diffusions Web et des groupes de discussion.

  • Pour consulter la Base de connaissances Microsoft et d’autres ressources techniques afin obtenir rapidement des réponses précises aux questions portant sur SMS, visitez le site Web Aide et support Microsoft (éventuellement en anglais). Pour rechercher un article sur une question spécifique, vous pouvez interroger la Base de connaissances en indiquant le numéro « Qxxxxxx » ou « xxxxxx » associé à ce thème.

Communication des commentaires

  • Afin que l’équipe en charge de la documentation de SMS puisse fournir les informations sur le produit les plus adaptées à vos besoins, veuillez nous faire part de vos commentaires. Envoyez vos commentaires sur la documentation à Documentation SMS.

Voir aussi

Concepts

Groupes d’ordinateurs pour SMS 2003
Fournisseurs de SMS 2003
Diagrammes SMS 2003
Rapports SMS 2003

Autres ressources

Sites et composants du SMS 2003 Management Pack
Groupes de règles SMS 2003
Scripts pour SMS 2003
Affichages Microsoft SMS 2003


Sites et composants du SMS 2003 Management Pack

Les composants SMS 2003 intègrent le serveur de site central SMS, la base de données du site SMS et la console Administrateur SMS, qui résident généralement sur le même serveur, tandis que chaque rôle du système de site réside sur un serveur dédié. Combinés aux rôles du système de site, un serveur et une base de données de site central constituent un site SMS. Un site SMS peut contenir plusieurs rôles du système de site en double. Par exemple, un site peut contenir plusieurs points d'accès client (CAP). Les sites SMS 2003 peuvent être organisés par niveaux. Un site SMS peut ne pas contenir certains rôles du système de site, comme un point de recherche de serveur.

Le SMS 2003 Management Pack est conçu pour analyser les composants serveur SMS. Ce pack d'administration ne permet pas d'analyser les fonctionnalités SMS sur des ordinateurs clients SMS. Toutefois, Operations Manager 2007 permet d'analyser d'autres applications résidant sur un client SMS.

Pour plus d'informations sur les composants de SMS 2003, voir la bibliothèque en ligne SMS 2003. Pour obtenir des liens vers la documentation SMS 2003, voir la section Ressources supplémentaires pour le Microsoft Systems Management Server 2003 Management Pack de ce guide.

Les principaux rôles et composants serveur sont les suivants :

  • Point d'accès client

  • Point de distribution

  • Point de gestion

  • Point de recherche de serveur

  • Point de rapport

  • Serveur de site

  • Base de données du site

  • Expéditeurs

  • Client avancé

  • Client hérité

  • Fournisseur SMS

  • Console Administrateur SMS

Point d'accès client

Le rôle Point d'accès client (CAP) est le point de contact entre les clients hérités et le serveur de site SMS. Il transmet au serveur de site toutes les données des clients hérités. Les ordinateurs des clients hérités contactent le CAP afin d'obtenir des informations de gestion issues du serveur de site SMS. Un CAP ne sert qu'un seul site SMS et est installé par défaut sur le serveur de site. Ce rôle remplit également les fonctions suivantes :

  • Fournir des fichiers et des instructions de configuration spécifiques pour le client hérité lors de l'installation du client et en cas de modification ultérieure.

  • Servir d'emplacement où les ordinateurs des clients hérités vérifient la présence d'annonces.

  • Recevoir des données des clients hérités, qui sont ensuite transférées au serveur de site SMS. Par exemple, lorsqu'un client effectue un inventaire matériel ou logiciel et crée un fichier de données d'inventaire, il envoie ces données au CAP. Les messages d'état générés par le client sont répliqués vers le CAP.

Point de distribution

Le point de distribution stocke les fichiers sources du package SMS utilisés par les clients SMS lors de l'installation de logiciels distribués par SMS. Lorsque l'administrateur SMS annonce la disponibilité d'un programme, l'annonce et les informations sur le programme sont disponibles pour les clients via un point d'accès client (CAP) pour les clients hérités ou via un point de gestion pour les clients avancés.

Lors de la configuration de SMS, le rôle Point de distribution est automatiquement attribué au serveur de site. L'administrateur SMS peut activer le service de transfert intelligent en arrière-plan (BITS) sur le point de distribution, ce qui permet d'utiliser le téléchargement incrémentiel de fichiers de package vers les clients avancés.

Les clients avancés font appel au service BITS pour détecter automatiquement la capacité de connexion réseau du client et optimiser les taux de transfert. Cette fonction n'est prise en charge que sur les clients exécutant le système d'exploitation Microsoft Windows 2000, Microsoft Windows XP Professionnel ou Microsoft Windows Server™ 2003.

Point de gestion

Le point de gestion est le point de contact principal entre les clients avancés et le serveur de site SMS. Un site SMS ne possède qu'un seul point de gestion par défaut, même si plusieurs points de gestion peuvent être configurés avec le service d'équilibrage de la charge réseau de Windows. À l'instar de la relation entre les points d'accès client et les clients hérités, un point de gestion remplit les fonctions suivantes :

  • Fournir des informations de configuration client spécifiques (également appelée « stratégie du client avancé ») pour le client avancé après l'installation du client.

  • Servir d'emplacement où les ordinateurs des clients avancés vérifient la présence d'annonces.

  • Rechercher les points de distribution pour les clients avancés.

  • Recevoir des informations d'inventaire, de contrôle de logiciel et d'état des clients hérités et les transférer au serveur de site SMS.

Point de recherche de serveur

Le point de recherche de serveur recherche les points d'accès client pour les clients hérités et les points de gestion pour les clients avancés. Il est essentiellement utilisé lors de l'installation du client. Ce rôle remplit les fonctions suivantes :

  • Rechercher un point de gestion pour le client avancé si celui-ci est configuré pour l'attribution de site SMS automatique.

  • Fournir aux clients avancés l'emplacement du point de gestion lors d'une installation du client lancée par script d'ouverture de session et lors d'une installation ne rassemblant pas suffisamment d'informations d'identification.

  • Fournir l'attribution de site SMS pour le client hérité et rechercher les points d'accès client lors d'une installation du client lancée par script d'ouverture de session.

Point de rapport

Un point de rapport est un serveur exécutant les services IIS (Internet Information Services) qui héberge le code pour l'éditeur de rapports, ainsi que les rapports supplémentaires. Il ne communique qu'avec le serveur de base de données du site SMS correspondant.

Client avancé

SMS 2003 répond au besoin d'informatique nomade grâce au client avancé, qui prend en charge toutes les fonctionnalités SMS, notamment la distribution de logiciels, la gestion des stocks et la résolution de problèmes à distance. Vous pouvez ainsi gérer indifféremment les utilisateurs nomades et sédentaires. Le client avancé fait appel au service BITS, une technologie Windows qui assure la connectivité pour toutes les opérations de gestion.

Client hérité

Vous pouvez utiliser le client hérité si votre organisation doit gérer des ordinateurs qui ne répondent pas aux exigences relatives à la prise en charge du client avancé. Il est possible d'activer, de configurer et de superviser les méthodes d'installation suivantes du client hérité :

  • Installation du client lancée par script d'ouverture de session

  • Installation poussée du client

  • Installation manuelle du client

Fournisseur SMS

Le fournisseur SMS traite les demandes de données issues de la base de données du site SMS. Ce rôle est installé sur le même ordinateur que le serveur ou la base de données du site SMS. Il est recommandé d'installer le fournisseur SMS et la base de données du site SMS sur le serveur de site. Le fournisseur SMS permet d'accéder aux données via la console Administrateur SMS installée sur le site.

Console Administrateur SMS

La console Administrateur SMS est l'interface utilisateur graphique servant à gérer SMS. Elle utilise un composant logiciel enfichable MMC (Microsoft Management Console) fourni avec le logiciel du produit SMS. Par défaut, la console Administrateur SMS est installée lors de l'installation d'un serveur de site principal, mais elle peut également être installée sur d'autres serveurs ou stations de travail.

Voir aussi

Concepts

Ressources supplémentaires pour le Microsoft Systems Management Server 2003 Management Pack
Groupes d’ordinateurs pour SMS 2003
Fournisseurs de SMS 2003
Diagrammes SMS 2003
Rapports SMS 2003

Autres ressources

Sites et composants du SMS 2003 Management Pack
Groupes de règles SMS 2003
Scripts pour SMS 2003
Affichages Microsoft SMS 2003


Groupes d’ordinateurs pour SMS 2003

Le SMS 2003 Management Pack fournit les groupes d’ordinateurs suivants :

  • Consoles Administrateur Microsoft SMS 2003

  • Clients avancés Microsoft SMS 2003

  • Serveurs de site central Microsoft SMS 2003

  • Clients Microsoft SMS 2003

  • Serveurs de point d'accès clients Microsoft SMS 2003

  • Serveurs de composants Microsoft SMS 2003 basés sur IIS

  • Serveurs de composants Microsoft SMS 2003 basés sur SMS Executive

  • Serveurs point de distribution Microsoft SMS 2003

  • Serveurs de point de gestion Microsoft SMS 2003

  • Serveurs de site principal Microsoft SMS 2003

  • Fournisseurs Microsoft SMS 2003

  • Serveurs de points de rapport Microsoft SMS 2003

  • Serveurs de site secondaire Microsoft SMS 2003

  • Serveurs expéditeurs Microsoft SMS 2003

  • Serveurs de point de recherche de serveur Microsoft SMS 2003

  • Serveurs Microsoft SMS 2003

  • Serveurs de site Microsoft SMS 2003

  • Clients hérités Microsoft SMS 2003

Voir aussi

Concepts

Ressources supplémentaires pour le Microsoft Systems Management Server 2003 Management Pack
Groupes d’ordinateurs pour SMS 2003
Fournisseurs de SMS 2003
Diagrammes SMS 2003
Rapports SMS 2003

Autres ressources

Sites et composants du SMS 2003 Management Pack
Groupes de règles SMS 2003
Scripts pour SMS 2003
Affichages Microsoft SMS 2003


Groupes de règles SMS 2003

Cette section répertorie les groupes de règles et les règles d'événements de Systems Management Server (SMS) 2003 Management Pack générant des événements et des alertes critiques. Référez-vous à Création dans la console Opérateur de Microsoft Operations 2007 pour consulter toutes les règles qui figurent dans ces groupes.

Clients SMS - Avancé

Le groupe de règles Clients SMS - Avancé comprend des règles relatives aux erreurs des clients avancés SMS.

  • Service SMS 2003 exécutant : hôte de l'agent SMS

  • Service associé SMS 2003 exécutant : service BITS (Background Intelligent Transfer Service)

  • Service associé SMS 2003 exécutant : infrastructure WMI

Points d'accès clients SMS

Le groupe de règles Points d'accès clients SMS comprend des règles relatives aux erreurs de point d'accès client SMS.

  • Service SMS 2003 exécutant : SMS_EXECUTIVE

Points de gestion SMS

Le groupe de règles Points de gestion SMS comprend des règles relatives aux erreurs de point de gestion SMS.

  • Service SMS 2003 exécutant : hôte de l'agent SMS

  • Service SMS 2003 exécutant : SMS_EXECUTIVE

  • Service associé SMS 2003 exécutant : Service de publication sur le Web

  • Service associé SMS 2003 exécutant : Service d'administration IIS

  • État de santé des points de gestion SMS 2003 : État

  • Seuil de performance SMS 2003 : enregistrements de données de découverte du point de gestion en retard de traitement et supérieurs à 10 000 sur trois heures

  • Seuil de performance SMS 2003 : inventaires matériels du point de gestion en retard de traitement et supérieurs à 10 000 sur trois heures

  • Seuil de performance SMS 2003 : inventaires logiciels du point de gestion en retard de traitement et supérieurs à 10 000 en trois heures

  • Seuil de performance SMS 2003 : collectes de fichiers du point de gestion en retard de traitement et supérieurs à 10 000 en trois heures

  • Seuil de performance SMS 2003 : Gestionnaire de relais du point de gestion en attente de traitement et supérieur à 10 000 en trois heures

  • Seuil de performance SMS 2003 : messages d'état du point de gestion en attente de traitement et supérieurs à 10 000 en trois heures

  • Seuil de performance SMS 2003 : processus - % Temps processeur (ccmexec) supérieur à 95 sur trois heures

Fournisseurs SMS

Le groupe de règles Fournisseurs SMS contient des règles pour les erreurs liées au composant Fournisseurs SMS de SMS 2003.

  • Service associé SMS 2003 exécutant : infrastructure WMI

Points de rapport SMS

Le groupe de règles Points de rapports SMS comprend des règles relatives aux erreurs de point de rapport SMS.

  • Service SMS 2003 exécutant : SMS_REPORTING_POINT

  • Service associé SMS 2003 exécutant : Service de publication sur le Web

  • Service associé SMS 2003 exécutant : Service d'administration IIS

Serveurs d'expéditeurs SMS

Le groupe de règles Serveurs d'expéditeurs SMS comprend des règles relatives aux erreurs des serveurs d'expéditeurs SMS.

  • Service SMS 2003 exécutant : SMS_EXECUTIVE

Points de recherche de serveur SMS

Le groupe de règles Points de recherche de serveur SMS comprend des règles relatives aux erreurs de point de recherche de serveur SMS.

  • Service associé SMS 2003 exécutant : Service de publication sur le Web

  • Service associé SMS 2003 exécutant : Service d'administration IIS

  • Service SMS 2003 exécutant : SMS_SERVER_LOCATOR_POINT

Serveurs SMS - Commun

Le groupe de règles Serveurs SMS - Commun comprend des règles relatives aux erreurs de tous les serveurs SMS.

  • Seuil de performance SMS 2003 : fichier d'échange - % d'utilisation supérieur à 98 sur trois heures

  • Seuil de performance SMS 2003 : processus - % Temps processeur (_Total) supérieur à 95 sur trois heures

Serveurs SMS reposant sur SMS Executive

Le groupe de règles Serveurs SMS reposant sur SMS Executive comprend des règles relatives aux erreurs des serveurs de site exécutant le service SMS Executive.

  • Seuil de performance SMS 2003 : processus - % Temps processeur (smsexec) supérieur à 95 en trois heures

Serveurs de base de données de site SMS

Le groupe de règles Serveurs de base de données de site SMS comprend des règles relatives aux erreurs des serveurs de base de données de site SMS.

  • Service SMS 2003 exécutant : SMS_SQL_MONITOR

  • Service associé SMS 2003 exécutant : MSSQLSERVER

  • Seuil de performance SMS 2003 : nombre de connexions SQL SMS supérieur à 500 sur deux heures

Serveurs de site SMS - Commun

Le groupe de règles Serveurs de site SMS - Commun comprend des règles relatives aux erreurs de tous les serveurs de site SMS.

  • Service SMS 2003 exécutant : SMS_SITE_COMPONENT_MANAGER

  • Service SMS 2003 exécutant : SMS_EXECUTIVE

  • Seuil de performance SMS 2003 : travaux du planificateur du serveur de site en retard de traitement et supérieurs à 10 000 en trois heures

  • Seuil de performance SMS 2003 : demandes d'expédition du planificateur du serveur de site en retard de traitement et supérieurs à 10 000 sur trois heures

  • Seuil de performance SMS 2003 : contrôles de logiciel du serveur de site en retard de traitement et supérieurs à 10 000 en trois heures

  • Seuil de performance SMS 2003 : inventaires logiciels en retard de traitement sur le serveur de site et supérieurs à 10 000 en trois heures

  • Seuil de performance SMS 2003 : inventaires matériels du serveur de site en retard de traitement et supérieurs à 10 000 sur trois heures

  • Seuil de performance SMS 2003 : enregistrements de données de découverte du serveur de site en retard de traitement et supérieurs à 10 000 en trois heures

Serveurs de site SMS - Principal

Le groupe de règles Serveurs de site SMS - Principal comprend des règles relatives aux erreurs de tous les serveurs de site principaux SMS.

  • Seuil de performance SMS 2003 : inventaires logiciels en retard de traitement sur le serveur de site et supérieurs à 10 000 en trois heures

  • Seuil de performance SMS 2003 : inventaires matériels du serveur de site en retard de traitement et supérieurs à 10 000 sur trois heures

Voir aussi

Concepts

Ressources supplémentaires pour le Microsoft Systems Management Server 2003 Management Pack
Groupes d’ordinateurs pour SMS 2003
Fournisseurs de SMS 2003
Diagrammes SMS 2003
Rapports SMS 2003

Autres ressources

Sites et composants du SMS 2003 Management Pack
Groupes de règles SMS 2003
Scripts pour SMS 2003
Affichages Microsoft SMS 2003


Fournisseurs de SMS 2003

Les types de fournisseurs de données utilisés par SMS 2003 Management Pack sont les suivants :

  • Journal d'application

  • Événement chronométré

  • Compteur de performances Windows NT

Voir aussi

Concepts

Ressources supplémentaires pour le Microsoft Systems Management Server 2003 Management Pack
Groupes d’ordinateurs pour SMS 2003
Diagrammes SMS 2003
Rapports SMS 2003

Autres ressources

Sites et composants du SMS 2003 Management Pack
Groupes de règles SMS 2003
Scripts pour SMS 2003
Affichages Microsoft SMS 2003


Scripts pour SMS 2003

SMS 2003 Management Pack contient des scripts Operations Manager 2007 qui s'exécutent automatiquement sur l'agent et des scripts qui doivent être exécutés par un administrateur. Cette section fournit des informations complémentaires sur certains de ces scripts.

Les scripts suivants sont exécutés automatiquement par l'Agent Operations Manager 2007 :

  • SMS 2003 Monitor SMS Status Messages

  • SMS 2003 Monitor Site System Summarizer

  • SMS 2003 Service Discovery – Client

  • SMS 2003 Service Discovery – Server

  • SMS 2003 Site Backup Event Suppression

  • SMS 2003 Monitor Management Point Health

  • SMS 2003: Monitor Management Point Availability

  • SMS 2003 Site Hierarchy Discovery

  • SMS 2003 Monitor SMS Inbox

  • SMS 2003 Monitor SMS Executive Crash Dumps

SMS 2003 Monitor SMS Status Messages

De nombreux problèmes dans SMS sont détectés et signalés de manière interne par le biais du système d'état SMS. Les messages d'état sont déclenchés par des composants SMS relativement à des situations qui présentent un intérêt pour un administrateur SMS.

Les messages d'état affluent vers la base de données d'un site SMS et remontent la hiérarchie du site jusqu'à la base de données du site parent. Il est possible de surveiller le système d’état SMS site par site, en interrogeant simplement la table des messages d’état SMS de la base de données d’un site spécifique.

Les messages d’état choisis pour la surveillance reflètent les événements les plus critiques aux yeux des administrateurs SMS. Lorsque l’un de ces messages est détecté dans la base de données, une alerte est générée.

Ce script effectue les opérations suivantes :

  • Il vérifie s’il est exécuté en mode géré sans agent. Si tel est le cas, le script prend fin immédiatement.

  • Il initialise les variables globales.

  • Il ouvre le fichier SMS 2003 Monitor SMS Status Messages.VarSet et lit le paramètre RecordID du dernier message d’état traité, pour chaque base de données du site SMS en cours de surveillance.

  • Il traite les messages d’état trouvés dans chaque base de données du site SMS sur l’ordinateur local.

  • Dans le fichier SMS 2003 Monitor SMS Status Messages.VarSet, il écrit le paramètre RecordID du dernier message d’état traité, pour chaque base de données du site SMS en cours de surveillance, puis ferme le fichier.

Le script SMS 2003 Monitor SMS Status Messages déclenche les événements dont l'ID d’événement correspond à l'ID du message d’état SMS signalé. Le tableau S.1 décrit le format de l’événement déclenché.

Tableau S.1 Format des événements déclenchés par le script SMS 2003 Monitor SMS Status Messages

Paramètre | Description
EventType | Réussite, erreur, avertissement ou information, suivant la gravité du message d’état SMS
EventNumber | ID du message d’état SMS
Category | Code du site SMS
LoggingDomain | Domaine de ressource de l’ordinateur
LoggingComputer | Nom NetBIOS de l’ordinateur
Paramètre 1 | Nom NetBIOS de l’ordinateur
Paramètre 2 | Nom du module SMS, tel que Serveur SMS
Paramètre 3 | Nom du composant SMS
Paramètre 4 | ID du message SMS
Paramètre 5 | Code d’erreur Win32
Paramètre 6 | Code du site parent ou de niveau supérieur
Paramètre 7 | Valeur RecordID du message d’état dans le tableau des messages d’état SMS
Description | "A new monitored SMS status message on machine <NetBIOS Name> from component <Component Name> with message ID <Message ID> was found in the site <Site Code> database.”

En outre, le script SMS 2003 Monitor SMS Status Messages signale des erreurs de script par le biais du numéro d’ID de message d’état 1102 :

EventType = Avertissement

EventNumber= 1102

Description = The script SMS 2003 Monitor SMS Status Messages running under processing rule <ScriptProcessingRuleName> encountered a runtime error. The error message will contain the text “Failed to <ErrorDescription>.”

Toutes les règles d’événement d’analyse des messages d’état SMS 2003 commencent par l’expression « État de SMS 2003 : » et se trouvent dans le groupe de règles Serveurs de base de données de site SMS.

  • État de SMS 2003 : surveillance des messages

La règle État de SMS 2003 : surveillance des messages lance le script à l’aide du fournisseur d’événement chronométré SMS 2003 Planifiez toutes les minutes, synchronisez à 00:02. Des informations de synthèse sont fournies dans la page de propriétés Base de connaissances de la règle.

  • État de SMS 2003 : erreur de script

La règle État de SMS 2003 : erreur de script surveille et signale tout événement lié à un script erroné pouvant être déclenché. Seul l'événement lié à un script erroné (numéro 1102) signale toutes les erreurs de script. Des informations sur la résolution de cette alerte sont fournies dans la page de propriétés Base de connaissances de la règle.

  • État de SMS 2003 : <status message name>

La règle État de SMS 2003 : <nom du message d’état> surveille et signale des événements de message d’état spécifiques. Des informations sur la résolution de cette alerte sont fournies dans la page de propriétés Base de connaissances de la règle.

Toutes les alertes décrivent l’événement sous la forme suivante, où $Description$ représente la description de événement :

$Ordinateur de connexion$ - "Nom de règle". $Description$

Le fichier SMS 2003 Monitor SMS Status Messages.VarSet permet de conserver la valeur RecordID du dernier message d’état traité, ce pour chaque base de données du site. Le fichier VarSet se trouve dans le répertoire Windows\Temp. Il s’agit d’un fichier délimité par des tabulations qui présente la forme suivante :

Copy Code
LastRecordID_NuméroRecordIDNomBD

Par exemple, LastRecordID_SMS_FLA, avec la valeur RecordID 477860, indique que le dernier paramètre RecordID traité à partir de la base de données du site nommée SMS_FLA porte le numéro 477860.

Lors de la mise à niveau du pack d’administration à partir d’une version antérieure, les informations suivantes figurent dans le fichier SMS 2003 Monitor SMS Status Messages.VarSet :

Copy Code
LastRecordID476743
LastRecordID_SMS_FLA477860

La première ligne, qui ne contient pas de nom de base de données, indique la version d’origine de la surveillance des messages d’état qui ne prenait pas en charge la surveillance de plusieurs bases de données. La seconde ligne, qui contient un nom de base de données, SMS_FLA, indique que la version actuelle de la surveillance des messages d’état prend en charge la surveillance de plusieurs bases de données.

Aucune action n’est entreprise pour utiliser la première ligne de données, car dans le cas de bases de données de site multiples, il est difficile de déterminer la base de données concernée. La première ligne de données n’est pas supprimée du fichier VarSet, car elle peut s’avérer utile pour évaluer les nouvelles modifications et pour faire en sorte que la surveillance des messages d’état commence par le paramètre RecordID adéquat après la mise à niveau.

SMS 2003 Monitor Site System Summarizer

Outil de synthèse d’état du système de site

L’Outil de synthèse d’état du système de site est une thread qui appartient au service SMS Executive et dont le rôle consiste à gérer l’état de tous les systèmes de site SMS définis. Par défaut, elle effectue une interrogation une fois par heure, à l’heure juste, afin de déterminer l’état actuel. Cet intervalle d’interrogation est défini dans le fichier de contrôle de site SMS. Il est recommandé de ne pas modifier l’intervalle d’interrogation. L’état est géré dans une table de la base de données du site SMS.

État DownSince du système de site

L’Outil de synthèse d’état du système de site suppose qu’un système de site est hors service lorsqu’il ne peut pas le contacter pendant l’un de ses intervalles d’interrogation. Cette situation peut être due à l’un des facteurs suivants :

  • Le système de site n’est pas activé, n’est pas connecté au réseau ou ne fonctionne pas correctement.

  • L’Outil de synthèse d’état du système de site SMS ne dispose pas d’une connexion, car aucune connexion n’est disponible.

  • L’Outil de synthèse d’état du système de site SMS ne dispose pas de droits d’accès suffisants pour se connecter au système de site.

  • Des problèmes réseau empêchent l’Outil de synthèse d’état du système de site SMS de se connecter au système de site.

  • Le système de site a été définitivement placé hors service.

Disponibilité basée sur l’Outil de synthèse d’état du système de site

Le script et le rapport de disponibilité des serveurs SMS 2003 indiquent la disponibilité en s’appuyant sur l’état de l’Outil de synthèse d’état du système de site. Les mesures de la disponibilité des serveurs SMS utilisent la valeur de Registre DownSince pour déterminer si un serveur est disponible.

Limites de la disponibilité basée sur l’Outil de synthèse d’état du système de site

Cette section explique les limites de l’utilisation de l’état de l’Outil de synthèse d’état du système de site par le script et le rapport de disponibilité des serveurs SMS 2003 pour indiquer la disponibilité. Les mesures de la disponibilité des serveurs SMS utilisent l’état « DownSince » pour déterminer si un serveur est disponible.

La surveillance de la disponibilité à partir de l’Outil de synthèse d’état du système de site présente les limites suivantes :

  • L’intervalle d’interrogation de l’Outil de synthèse d’état du système de site est d’une heure. Cet intervalle laisse suffisamment de temps à l’Outil de synthèse d’état du système de site pour interroger tous les systèmes de site. Pour des raisons de performances, l’intervalle ne peut pas être modifié. Le délai d’attente de l’outil de synthèse est contrôlé par la propriété Startup Schedule du fichier de contrôle de site, pas par la propriété Wakeup Interval. Cela signifie que la modification de la valeur par défaut 60 de la propriété Wakeup Interval est sans effet. En outre, la modification de la propriété Startup Schedule est également sans effet. Sa valeur par défaut correspond à un cycle de 15 minutes mais l’Outil de synthèse d’état du système de site interroge les systèmes de site une fois par heure, à l’heure juste, quelle que soit la valeur de la propriété Startup Schedule.

  • La méthodologie de la disponibilité ne considère qu’un site est indisponible que si deux événements successifs Outil de synthèse d’état du système de site SMS 2003 : Le système de site est probablement hors service se produisent en l’espace de deux heures. Ce dispositif permet de prendre en compte les pannes réseau temporaires. Cela signifie que la disponibilité se voit affecter une interruption de service théorique de deux heures, même si le site a été indisponible pendant une courte durée.

  • Il existe de nombreuses situations d’indisponibilité de SMS que l’Outil de synthèse d’état du système de site ne contrôle pas. Par exemple, l’Outil de synthèse d’état du système de site ne considère pas que SMS est indisponible si les services SMS ne sont pas en cours d’exécution ou que la base de données du site SMS est indisponible, de même que lorsque le service SQL Server est arrêté.

  • Les données sur la disponibilité concernent au premier chef les ordinateurs qui hébergent plusieurs rôles serveur SMS. Le temps d’arrêt est calculé en fonction des alertes générées pour un système de site arrêté. Une simple alerte possède une pondération de temps d’arrêt de deux heures. L’Outil de synthèse d’état du système de site écrit l’état « DownSince » actuel pour chaque rôle système du site et objet de site hébergé sur un ordinateur dans la table Outil de synthèse d’état du système de site de la base de données.

Le script de surveillance de l’Outil de synthèse d’état du système de site examine chaque rôle système du site dans la table Outil de synthèse d’état du système de site. Si un système de site est marqué comme étant arrêté, il déclenche un événement. Une alerte est ensuite générée en fonction de cet événement. Plusieurs rôles peuvent générer plusieurs alertes, ce qui crée des temps d’arrêt de longue durée. Cela peut se traduire par des pourcentages de disponibilité négatifs, suivant l’intervalle considéré.

Chaque rôle serveur SMS, à l’exception du point de distribution SMS, établit deux rôles serveur SMS par défaut, l’un pour le rôle proprement dit, l’autre pour le serveur de composants SMS. Par exemple, dans le cas d'un système de site qui héberge un point de recherche de serveur et un point de rapport, si le serveur a été hors ligne pendant plus de deux heures (deux intervalles d’interrogation de l’Outil de synthèse d’état du système de site), l’Outil de synthèse d’état du système de site marque ces deux rôles, et leurs rôles serveur de composants SMS, comme étant arrêtés.

Toutefois, seules trois alertes, une pour chaque rôle de serveur et une pour le serveur de composants physique hébergeant deux rôles de serveur, seraient déclenchées par intervalle d’interrogation pendant la période de deux heures. Cela générerait un résultat de disponibilité négatif, car six heures seraient marquées comme étant indisponibles pour la période de deux heures.

  • La planification sur 60 minutes, avec un décalage de 10 minutes par rapport à l’heure juste, a été définie par défaut de manière à ce que le script SMS 2003 Monitor Site System Summarizer s’exécute 10 minutes après le début de l’intervalle d’interrogation de 1 heure de l’Outil de synthèse d’état du système de site. Si l’outil de synthèse met plus de 10 minutes pour terminer son cycle, le décalage du fournisseur d’événement chronométré doit être augmenté en conséquence. Sinon, les messages d’état du système de site les plus récents sont ignorés.

SMS 2003: Monitor Management Point Availability

Le script SMS 2003 Monitor Management Point Availability prend en charge le rapport de disponibilité du point de gestion. La disponibilité repose sur l’état de fonctionnement d’un point de gestion et tire parti de la valeur d’état de fonctionnement suivante figurant dans le Registre :

Valeur DWORD HKEY_LOCAL_MACHINE\Microsoft\SMS\MP\MPHealthState

En fonction d’une planification configurable et d’un intervalle de création de rapports, le script lit, puis signale, par le biais d’un événement Operations Manager 2007, la durée de l’état de dysfonctionnement (valeur de Registre est 1, pas 0).

Ces événements liés aux données sur la disponibilité sont écrits dans les bases de données OperationsManager et OperationsManagerDW. Un rapport Operations Manager 2007 peut ensuite être exécuté, qui affiche la durée d’arrêt totale du point de gestion pendant un intervalle donné, ainsi qu’un pourcentage de disponibilité.

La valeur de Registre MPHealthState est gérée par le gestionnaire de contrôle de point de gestion. Elle est mise à jour toutes les six minutes.

Ce script effectue les opérations suivantes :

  • Il vérifie s’il est exécuté en mode géré sans agent. Si tel est le cas, le script prend fin immédiatement. Étant donné que le script utilise un fichier VarSet local pour la conservation des variables, l’Agent Operations Manager 2007 doit être installé.

  • Il initialise les variables globales.

  • Il récupère les paramètres d’entrée ScheduledInterval et ReportingInterval, en minutes.

  • Il vérifie que les paramètres d’entrée ne sont pas vides, ni égaux à 0 ou négatifs. S’ils le sont, un événement lié à un script erroné est déclenché, indiquant qu’une valeur non valide a été spécifiée. En outre, le script vérifie que la valeur ReportingInterval n’est pas inférieure à la valeur ScheduledInterval. Si cette condition n’est pas respectée, un événement lié à un script erroné est déclenché indiquant que ReportingInterval ne peut pas être inférieure à ScheduledInterval. Les deux valeurs implémentent un type Lng et ne peuvent pas dépasser 2147483647 (2G -1).

  • Il ouvre le fichier SMS 2003 Monitor Management Point Availability.VarSet et copie son contenu dans une collection locale. Si le fichier n’existe pas, aucun événement lié à un script erroné n’est déclenché. Si le fichier existe, mais qu’il ne peut pas être ouvert, un événement lié à un script erroné est déclenché.

  • Il vérifie la disponibilité du point de gestion.

    • Si la version actuelle de SMS est antérieure à la version 2.50.3067.0000, le script prend fin sans déclencher d’erreur, en raison de l’absence de la valeur de Registre MPHealthState. Le fichier journal des réponses de l’agent, AgentResponses-Configuration Group Name.log, contient la déclaration « Monitoring Management Point health is not supported on this SMS build ». Vous pouvez activer l’enregistrement en attribuant la valeur 1 au paramètre DWORD EnableActiveDebugging, rattaché à la clé HKEY_LOCAL_MACHINE\SOFTWARE\Mission Critical Software\OperationsManager.

    • Il récupère l’état de fonctionnement actuel du point de gestion à partir de la valeur de Registre DWORD HKEY_LOCAL_MACHINE\Microsoft\SMS\MP\MPHealthState. Si la valeur ne peut pas être récupérée, le script prend fin sans déclencher d’erreur, car le gestionnaire de contrôle de point de gestion ne l’a toujours pas créée.

    • Il récupère les date et heure de début dans la collection VarSet. Si c’est la première fois que le script a été exécuté et qu’il s’agit du début d’une nouvelle période de création de rapports, il n’existe aucune entrée. Le script initialise la durée et la date de début dans la collection VarSet, puis prend fin sans déclencher d’erreur. Il définit la durée sur 0 et la date de début sur les date et heure actuelles.

    • En ce qui concerne l’intervalle de création de rapports actuel, si la valeur de Registre MPHealthState est égale à 1, le script incrémente la durée indisponible dans la collection VarSet, en fonction de l’intervalle de planification spécifié.

    • Il indique, en créant un événement lié aux données sur la disponibilité, si l’intervalle de création de rapports s’est écoulé et si le point de gestion a été indisponible. Le script réinitialise la durée à 0 et la date de début dans la collection VarSet à l’heure locale actuelle pour la période de création de rapports suivante.

    • Si une erreur se produit pendant la vérification de la disponibilité du point de gestion, une erreur de script est déclenchée.

Numéro d'événement = 1102

Type d'événement = Avertissement

Message = "The script ‘SMS 2003 Monitor Management Availability' running under processing rule <ProcessingRuleName> encountered a runtime error." CrLf "Failed to check Management Point availability.” <ErrorString>

  • Il écrit le contenu de la collection VarSet dans le fichier local SMS 2003 Monitor Management Point Availability.VarSet, puis ferme le fichier. Si le fichier n’existe pas, il est créé. Si aucune variable VarSet n’était définie, aucune entrée correspondante n’apparaît dans le fichier. Si une erreur se produit lors de l’écriture du fichier, le script déclenche une erreur de script.

SMS 2003: Monitor SMS Inbox

SMS effectue la plupart de ses activités côté serveur fondamentales en réalisant des opérations de lecture et d’écriture dans les fichiers de ses boîtes de réception. Lorsque les boîtes de réception de SMS sont anormalement saturées, cela signifie clairement que les opérations de traitement de SMS prennent du retard. Cette situation peut avoir de nombreuses causes, telles que, mais pas exclusivement, des fichiers incorrects, l’arrêt de processus, le manque d’espace disque ou un niveau d’activité de distribution de logiciels inhabituel. De tels problèmes sont assez rares, mais sérieux pour les clients qui possèdent un nombre conséquent de sites.

Certains des compteurs de performance pour les boîtes de réception de SMS mesurent le nombre d’éléments mis en file d’attente par le composant du service et non le nombre réel d’éléments en attente de traitement sur le disque. Le composant du service SMS met à jour le compteur de performance après avoir passé en revue sa file d’attente actuelle. Cela peut entraîner la mise à jour très occasionnelle des compteurs de performance, empêchant ainsi la détection en temps opportun des files d'attente sérieuses. Le nouveau script SMS 2003: Monitor SMS Inbox ajoute une surveillance directe en dénombrant les fichiers situés dans les boîtes de réception du serveur SMS critiques et alerte l’administrateur par le biais d'Operations Manager 2007 lorsque le nombre de fichiers dans une boîte de réception particulière dépasse une valeur de seuil configurable par l’utilisateur.

Toutes les règles se trouvent dans le groupe de règles de traitements Serveurs de site SMS - Commun, qui cible ces règles sur les sites centraux, principaux et secondaires. Le seuil transmis au script peut être configuré au moyen d’un remplacement.

Pour des raisons liées aux performances, ces règles ne visent pas les points de gestion ou tout autre rôle de système de site SMS.

Planification et configuration facultative

Pour réduire au minimum l’impact de l’analyse des boîtes de réception sur les performances, les règles pertinentes sont synchronisées de manière à être exécutées une fois par jour. Les règles sont échelonnées par intervalles de 15 minutes, avec un démarrage à 01:00, de sorte qu’une seule règle soit exécutée à un moment donné. Par exemple, la première règle dénombre les fichiers présents dans la première boîte de réception à 01:00. La règle suivante dénombre les fichiers présents dans la deuxième boîte de réception à 01:15, et ainsi de suite, jusqu’à ce que toutes les boîtes de réception aient été traitées.

Vous pouvez modifier cette planification en suivant la procédure habituelle qui permet de planifier l’exécution d’un script de règle dans Operations Manager 2007. Aucune configuration initiale n’est requise pour l’activation de cette fonctionnalité. Voici les modifications que vous pouvez apporter à la configuration :

  • modifier la valeur de seuil par défaut pour chaque boîte de réception ;

  • modifier la planification des différentes règles de boîte de réception.

Vous pouvez apporter ces modifications facultatives à la configuration en suivant la procédure habituelle qui permet de configurer les règles d’événement de seuil dans n’importe quel pack d’administration.

Alertes et valeurs de seuil

Une alerte est générée chaque fois que la valeur de seuil configurée pour une règle de boîte de réception spécifique est atteinte à chaque traitement de la règle d’analyse. Une alerte d’erreur de script est générée chaque fois que le script rencontre une valeur de seuil non valide ou une erreur de tentative de contrôle du nombre de fichiers dans chaque boîte de réception.

Pour modifier les valeurs de seuil des performances

  1. Dans la console Administrateur d'Operations Manager 2007, cliquez sur Création.

  2. Dans le volet Création, accédez à Création / Objets du pack d'administration / Analyseur.

  3. Dans le volet Analyseurs, remplacez l'étendue par Serveur SMS.

  4. Accédez à SMS Server / Entity Health / MOM 2005 Computer Role Health, puis développez le rôle de serveur à modifier.

    • DB - Database server

    • MP - Management point server

    • SS - Site server

  5. Double-cliquez sur la règle de contrôle des seuils de performances à modifier. La boîte de dialogue Performance Threshold Properties s’ouvre.

  6. Sélectionnez l’onglet Configuration.

  7. Cliquez sur Modifier. La boîte de dialogue Configuration Xml s’ouvre.

  8. Dans le texte XML, modifiez la valeur de seuil concernée.

    • Définissez le paramètre <ValueExpression> imbriqué dans le paramètre <CriticalErrorExpression> pour modifier le seuil d’erreur critique.

    • Définissez le paramètre <ValueExpression> imbriqué dans le paramètre <WarningExpression> pour modifier le seuil d’avertissement.

  9. Cliquez sur OK. Cliquez sur OK. Les valeurs de seuil modifiées sont distribuées aux serveurs.

La valeur de seuil par défaut pour chaque règle d’analyse de boîte de réception est définie sur 10 000. Vous devez configurer les valeurs de seuil du paramètre FileCountThreshold du script SMS 2003: Monitor SMS Inbox en fonction de votre environnement. Les valeurs de seuil valides sont comprises entre 1 et 2147483647 (0x7FFFFFFF) inclus. Les valeurs de seuil non valides sont zéro (0) et les nombres supérieurs à 2147483647, car ceux-ci généreraient des nombres négatifs dans la plage sur 32 bits.

Pour plus d’informations sur les dossiers des boîtes de réception et sur leur utilisation dans Systems Management Server, consultez la rubrique correspondante sur le site Aide et support Microsoft (éventuellement en anglais).

Script SMS 2003 Monitor SMS Executive Crash Dumps

Ce script se trouve dans le dossier Scripts de la console Administrateur SMS et porte le nom SMS 2003 Monitor SMS Executive Crash Dumps. Il effectue les opérations suivantes :

  • Il détermine si l’ordinateur cible fonctionne en mode sans agent. Si tel est le cas, le script prend fin immédiatement. Étant donné que ce script utilise un fichier VarSet local pour la conservation des variables, l’Agent Operations Manager 2007 doit être installé sur tous les ordinateurs cibles.

  • Il ouvre le fichier local SMS 2003 Monitor SMS Executive Crash Dumps.VarSet, puis copie son contenu dans une collection. Si le fichier n’existe pas, aucun événement lié à un script erroné n’est déclenché. Si le fichier existe, mais qu’il ne peut pas être ouvert, un événement lié à un script erroné contenant le message suivant est déclenché :

Failed to load script variables.

  • Il vérifie si un nouveau vidage sur incident s’est produit depuis le dernier contrôle. Si tel est le cas, le script déclenche un événement pour signaler le nouveau vidage sur incident. Pour déclencher l’événement lié à un script erroné, le script procède comme suit :

    • Il récupère le répertoire d’installation de SMS dans la clé de Registre SMS Identification dont la valeur est « HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Identification\ Installation Directory ». Si le script ne peut pas récupérer le chemin d’accès, il déclenche un message d’événement lié à un script erroné contenant le texte suivant, puis prend fin :

Failed to read registry value.

  • Il construit le chemin d’accès complet du répertoire CrashDumps en ajoutant « \Logs\CrashDumps » au répertoire d’installation de SMS récupéré.

  • Il vérifie si le répertoire CrashDumps existe. Si ce n’est pas le cas, le script consigne le fait qu’il a été impossible de vérifier l’existence du dossier, puis prend fin immédiatement. Le fichier journal des réponses de l’agent, AgentResponses-Configuration Group Name.log, contient la déclaration suivante :

Failed to verify existence of crash dump directory : <CrashDumpsPath>.

Vous pouvez activer l’enregistrement en attribuant la valeur 1 au paramètre DWORD EnableActiveDebugging, rattaché à la clé HKEY_LOCAL_MACHINE\SOFTWARE\Mission Critical Software\OperationsManager.

  • Il récupère, dans la collection VarSet, la date de création du dossier du dernier vidage sur incident.

  • Il vérifie si de nouveaux vidages sur incident ont été créés et n’agit que sur le plus récent. Pour déterminer le plus récent, il se base sur la date de création de dossier enregistrée du dernier vidage sur incident, si celle-ci est disponible. La comparaison des dates et heures porte sur la création des dossiers, à la seconde près.

  • Si un nouveau vidage sur incident s’est produit ou que c’est la première fois que le script a été exécuté, le script consigne et crée l’événement 1710, en spécifiant le dossier et le chemin d’accès du nouveau vidage sur incident. Le script enregistre la date de création du dossier du vidage sur incident dans la collection VarSet. Si aucun vidage sur incident ne s’est produit, cela est consigné.

  • Il écrit le contenu de la collection VarSet dans le fichier local SMS 2003 Monitor SMS Executive Crash Dumps.VarSet, puis ferme le fichier. Si le fichier n’existe pas, il est créé. Si aucune variable VarSet n’était définie, aucune entrée correspondante n’apparaît dans le fichier. Si une erreur se produit lors de l’écriture du fichier, un message d’événement lié à un script erroné contenant le texte suivant est déclenché : Failed to save script variables.

SMS 2003 : événement lié à la surveillance des vidages sur incident de SMS Executive

Le script SMS 2003 Monitor SMS Executive Crash Dumps signale les incidents par le biais de l’événement 1710, décrit ci-après :

EventType = Erreur

EventNumber = 1710

Category = Code du site SMS

Description = SMS Executive in site “XXX” has crashed. For details, see crash dump information under <Drive> \SMS\Logs\CrashDumps\NewFolder.

Événement d'erreur du script SMS 2003 Monitor SMS Executive Crash Dumps

Le script « SMS 2003 Monitor SMS Executive Crash Dumps » signale les erreurs de script liées à l’exécution par le biais de l’événement 1102.

EventType = Avertissement

EventNumber = 1102

Description = The script “SMS 2003 Monitor SMS Executive Crash Dumps” running under processing rule SMS 2003 Crash Dumps: Monitoring SMS Executive encountered a runtime error. CrLf “Failed to <Message>." ErrorString

Script de disponibilité des serveurs SMS 2003

SMS est une application d’entreprise cruciale pour la gestion des configurations de bureau. Les clients doivent effectuer le suivi de la disponibilité de ses services. Le pack d’administration fournit un exemple de script Microsoft SQL Server™ qui permet de calculer la disponibilité du système de site SMS en fonction des alertes déclenchées en réponse à la communication d’un état arrêt par l’Outil de synthèse d’état du système de site SMS. La disponibilité peut être déterminée sur n’importe quel nombre de jours spécifié. Cette métrique peut être utilisée dans le cadre des accords sur le niveau de service établis.

Limites du script de disponibilité des serveurs SMS 2003

Le script de disponibilité des serveurs SMS 2003 présente les limites suivantes.

Les données affichées ne concernent que l’intervalle de nettoyage de base de données Operations Manager 2007. Par défaut, le script renvoie les données relatives aux sept derniers jours et aux 30 derniers jours. Toutefois, étant donné que la base de données OperationsManager utilise un intervalle de nettoyage de 4 jours, l’exécution du script avec des intervalles de sept et 30 jours renvoie les mêmes résultats. Si des rapports reflétant des périodes plus longues sont requis, il est nécessaire d’augmenter l’intervalle de nettoyage ou d’utiliser le rapport de disponibilité des serveurs SMS 2003, qui s’exécute sur la base de données OperationsManagerDW, emplacement de stockage à long terme des données opérationnelles. Pour les périodes plus courtes, les intervalles de 7 et 30 jours définis dans le script doivent être modifiés.

Algorithme du script

Une fois par heure, l’Outil de synthèse d’état du système de site essaie de contacter chaque système de site. S’il ne parvient pas à contacter un système de site, il marque cet ordinateur comme étant arrêté, dans la table Outil de synthèse d’état du système de site. Pour réduire le nombre de faux rapports liés à cette condition, le pack d’administration consolide les événements et ne déclenche une alerte que si deux événements se produisent dans une période de deux heures. Lorsque vous exécutez la procédure stockée, celle-ci calcule le nombre d’alertes « Le système de site est probablement hors service » déclenchées pendant le nombre de jours spécifié, soustrait le temps d’arrêt de la durée totale disponible, puis renvoie un pourcentage de disponibilité pour cette période. Si un ordinateur n’a consigné aucune alerte « Le système de site est probablement hors service » pendant l’intervalle spécifié, sa disponibilité calculée est de 100 %.

Vous n’avez pas besoin d’exécuter le script plus d’une fois par intervalle de sept jours, sauf si vous souhaitez observer une tendance quotidienne.

Par défaut, le script renvoie les données relatives aux sept derniers jours et aux 30 derniers jours. Si vous spécifiez un intervalle de données plus long, vous obtenez une estimation plus précise du temps de fonctionnement du serveur. N’attribuez pas aux intervalles une période plus longue que le cycle de nettoyage de base de données Operations Manager 2007.

Les exemples suivants montrent que plus la moyenne des données porte sur une période étendue, plus la disponibilité du serveur est élevée :

  • Si deux événements sont générés pour un ordinateur en l’espace de deux heures, une alerte est générée. Si une alerte est générée au cours des sept derniers jours, les calculs sont les suivants :

    • Nombre total d’heures dans sept jours = 7 * 24 = 168

    • Nombre total d’heures d’arrêt = 1 * 2 = 2

    • Nombre total d’heures de fonctionnement = (168 - 2) = 166

    • Pourcentage de disponibilité = (166 / 168) * 100 = 98,809 %

  • Si une alerte est générée au cours des 30 derniers jours, les calculs sont les suivants :

    • Nombre total d’heures dans 30 jours = 30 * 24 = 720

    • Nombre total d’heures d’arrêt = 1 * 2 = 2

    • Nombre total d’heures de fonctionnement = (720 - 2) = 718

    • Pourcentage de disponibilité = (718 / 720) * 100 = 99,72 %

  • Si une alerte est générée au cours des 84 derniers jours, les calculs sont les suivants :

    • Nombre total d’heures dans 84 jours = 84 * 24 = 2016

    • Nombre total d’heures d’arrêt = 1 * 2 = 2

    • Nombre total d’heures de fonctionnement = (2016 - 2) = 2014

    • Pourcentage de disponibilité = (2014 / 2016) * 100 = 99,9 %

Les exemples suivants montrent que la disponibilité du serveur est tributaire du nombre d’alertes consignées au cours d’une période donnée :

  • Si deux alertes sont générées au cours des 30 derniers jours, les calculs sont les suivants :

    • Nombre total d’heures dans 30 jours = 30 * 24 = 720

    • Nombre total d’heures d’arrêt = 2 * 2 = 4

    • Nombre total d’heures de fonctionnement = (720 -4) = 716

    • Pourcentage de disponibilité = (716 / 720) * 100 = 99,44 %

  • Si trois alertes sont générées au cours des 30 derniers jours, les calculs sont les suivants :

    • Nombre total d’heures dans 30 jours = 30 * 24 = 720

    • Nombre total d’heures d’arrêt = 3 * 2 = 6

    • Nombre total d’heures de fonctionnement = (720 -6) = 714

    • Pourcentage de disponibilité = (714 / 720) * 100 = 99,16 %

L’intervalle d’interrogation de l’Outil de synthèse d’état du système de site est calé sur une heure et ne peut pas être modifié par le biais de la console Administrateur SMS. La modification de cet intervalle n’améliore pas la précision de ce script. Il est possible de modifier l’intervalle de consolidation des événements, mais cela n’est pas recommandé, car la précision du résultat ne s’en trouve pas améliorée. En fait, la réduction de l’intervalle de consolidation rend les résultats moins fiables, car l’intervalle de consolidation de deux heures réduit les faux résultats dus à une panne réseau temporaire.

Voir aussi

Concepts

Ressources supplémentaires pour le Microsoft Systems Management Server 2003 Management Pack
Groupes d’ordinateurs pour SMS 2003
Fournisseurs de SMS 2003
Diagrammes SMS 2003
Rapports SMS 2003

Autres ressources

Sites et composants du SMS 2003 Management Pack
Groupes de règles SMS 2003
Scripts pour SMS 2003
Affichages Microsoft SMS 2003


Affichages Microsoft SMS 2003

SMS 2003 Management Pack propose les affichages communs suivants :

  • Alertes

  • Événements

  • Diagramme Hiérarchie de site SMS 2003

  • Affichage des états

  • État de la tâche

  • Général

  • Performances

Les affichages suivants, personnalisés pour SMS 2003, sont également disponibles :

Diagramme Hiérarchie de site SMS 2003

  • Hiérarchie SMS 2003

Général

  • Alertes du serveur de site central SMS au cours des dernières 72 heures

  • Nouvelles alertes des dernières 72 heures

Affichages des performances

Il est possible de configurer les affichages afin de représenter des données d'ordinateurs spécifiques par affichage. Pour cela, il est conseillé de copier l'affichage à personnaliser dans Mon espace de travail, de renommer l'affichage et de le personnaliser en fonction de vos besoins. Pour disposer d'un graphique moins complexe, vous pouvez sélectionner individuellement le compteur pour les ordinateurs qui vous intéressent.

Retards de traitement\Points de gestion

  • Enreg de données de découverte en retard de traitement au cours des dernières 48 heures

  • Collectes de fichiers en retard de traitement au cours des dernières 48 heures

  • Inventaires matériels en retard de traitement au cours des dernières 48 heures

  • Relais en retard de traitement au cours des dernières 48 heures

  • Inventaires logiciels en retard de traitement au cours des dernières 48 heures

  • Messages d'état en retard de traitement au cours des dernières 48 heures

Retards de traitement\Serveurs de site

  • Enreg de données de découverte en retard de traitement au cours des dernières 48 heures

  • Inventaires matériels en retard de traitement au cours des dernières 48 heures

  • Travaux du planificateur en retard de traitement au cours des dernières 48 heures

  • Demandes d'expédition du planificateur en retard de traitement au cours des dernières 48 heures

  • Inventaires logiciels en retard de traitement au cours des dernières 48 heures

  • Contrôles de logiciel en retard de traitement au cours des dernières 48 heures

Général\Serveurs de point de gestion

  • Disque logique au cours des dernières 48 heures

  • Mémoire au cours des dernières 48 heures

  • Processeur au cours des dernières 48 heures

Général\Serveurs de site

  • Disque logique au cours des dernières 48 heures

  • Mémoire au cours des dernières 48 heures

  • Processeur au cours des dernières 48 heures

Remarque
Le fournisseur de performances de l'affichage Disque logique au cours des dernières 48 heures est installé en même temps que Microsoft Windows Server Base Operating System Management Pack.

Taux de traitement

  • *Ensemble des taux de traitement des messages sur un serveur de point de gestion SMS 2003 au cours des dernières 24 heures

  • *Ensemble des taux de traitement des rapports sur un serveur de point de gestion SMS 2003 au cours des dernières 24 heures

  • *Ensemble des taux de traitement des rapports sur un serveur de site SMS 2003 au cours des dernières 24 heures

Taux de traitement\Serveurs de point de gestion

  • Enreg de données de découverte/sec au cours des dernières 24 heures

  • Tentatives de connexion à la base de données du GD/sec au cours des dernières 24 heures

  • Enreg de données de découverte du GD/sec au cours des dernières 24 heures

  • Demandes de conversion de données de découverte du GD/sec au cours des dernières 24 heures

  • Emplacement de points de distribution du GD/sec au cours des dernières 24 heures

  • Demandes de conversion d'inventaire matériel du GD/sec au cours des dernières 24 heures

  • Inventaires matériels du GD/sec au cours des dernières 24 heures

  • Demandes ISAPI du GD/sec au cours des dernières 24 heures

  • Demandes de paramètres d'ordinateur du GD/sec au cours des dernières 24 heures

  • Demandes de version du package du GD/sec au cours des dernières 24 heures

  • Inventaires logiciels du GD/sec au cours des dernières 24 heures

  • Demandes de corps de stratégie logic. du GD/sec au cours des dernières 24 heures

  • Demandes d'ID de stratégie logicielle du GD/sec au cours des dernières 24 heures

  • État du Gestionnaire de distribution/sec au cours des dernières 24 heures

  • Nbre total de demandes de paramètres du GD/sec au cours des dernières 24 heures

  • Emplacements de points de distribution/sec au cours des dernières 24 heures

  • Demandes d'obtention d'authentification (GetAuth)/sec au cours des dernières 24 heures

  • Demandes d'obtention de stratégie (GetPolicy)/sec au cours des dernières 24 heures

  • Inventaires matériels/sec au cours des dernières 24 heures

  • Demandes ISAPI/sec au cours des dernières 24 heures

  • Emplacements de point de gestion/sec au cours des dernières 24 heures

  • Demandes d'attrib de stratégie/sec au cours des dernières 24 heures

  • Rapports de relais/sec au cours des dernières 24 heures

  • Inventaires logiciels/sec au cours des dernières 24 heures

  • Nbre procédures stockées exécutées/sec au cours des dernières 24 heures

  • Messages d'état/sec au cours des dernières 24 heures

  • Nbre total d'enreg de données de découverte au cours des dernières 24 heures

  • Nbre total d'enreg de données de découverte du GD au cours des dernières 24 heures

  • Nbre total d'inventaires matériels du GD au cours des dernières 24 heures

  • Nbre total de demandes ISAPI du GD envoyées au cours des dernières 24 heures

  • Nbre total de demandes ISAPI du GD reçues au cours des dernières 24 heures

  • Nbre total d'inventaires logiciels du GD au cours des dernières 24 heures

  • Nbre total de messages d'état du Gestionnaire de distribution au cours des dernières 24 heures

  • Nbre total des inventaires matériels au cours des dernières 24 heures

  • Nbre total des rapports de relais au cours des dernières 24 heures

  • Nbre total d'inventaires logiciels au cours des dernières 24 heures

  • Nbre total des messages d'état au cours des dernières 24 heures

Taux de traitement\Serveurs de base de données de site

  • Connexions utilisateur SQL Server au cours des dernières 24 heures

Taux de traitement\Serveurs de site

  • Enreg de données de découverte/min au cours des dernières 24 heures

  • Inventaires matériels par minute au cours des dernières 24 heures

  • Inventaires logiciels par minute au cours des dernières 24 heures

  • Messages d'état/min au cours des dernières 24 heures

  • Contrôle de logiciel par minute au cours des dernières 24 heures

  • Nbre total d'enreg de données de découverte au cours des dernières 24 heures

  • Nbre total des inventaires matériels au cours des dernières 24 heures

  • Nbre total d'inventaires logiciels au cours des dernières 24 heures

  • Nbre total des messages d'état au cours des dernières 24 heures

  • Nombre total de contrôles de logiciel au cours des dernières 24 heures

Voir aussi

Concepts

Ressources supplémentaires pour le Microsoft Systems Management Server 2003 Management Pack
Groupes d’ordinateurs pour SMS 2003
Fournisseurs de SMS 2003
Diagrammes SMS 2003
Rapports SMS 2003

Autres ressources

Sites et composants du SMS 2003 Management Pack
Groupes de règles SMS 2003
Scripts pour SMS 2003
Affichages Microsoft SMS 2003


Diagrammes SMS 2003

Le SMS 2003 Management Pack fournit un diagramme topologique pour sa hiérarchie SMS. Les serveurs de site et les systèmes de site s'affichent avec leurs relations et des informations contextuelles. Les diagrammes topologiques intègrent des données logiques telles que les hiérarchies et les sites, ainsi que des données physiques, comme les serveurs de site et les systèmes de site. Les hiérarchies SMS 2003 pouvant être volumineuses, vous pouvez focaliser la vue de la hiérarchie sur un groupe d'ordinateurs SMS 2003 à l'aide du filtre Groupe.

Pour assurer la prise en charge des diagrammes topologiques pour le SMS 2003 Management Pack dans Operations Manager 2007, les conditions ci-dessous doivent être respectées :

  • SMS 2003 SP3 est installé sur les serveurs SMS concernés par les diagrammes

  • Les diagrammes topologiques doivent être activés

  • Chaque rôle de site doit être configuré en fonction d'un nom de domaine complet (FQDN) à l'aide de la console Administrateur SMS 2003

Pour que la détection de la topologie puisse générer un diagramme de la hiérarchie SMS 2003, les ordinateurs Fournisseur SMS doivent être gérés, un agent doit être installé sur ces ordinateurs et l'agent proxy doit être activé pour les autres ordinateurs. En outre, pour pouvoir afficher les connecteurs entre les serveurs de site et les systèmes de site, ces derniers doivent être détectés par un processus de détection SMS et doivent être membres du regroupement Tous les systèmes.

La détection est effectuée pour chaque site, en commençant par les sites principaux, les sites secondaires étant détectés dans le cadre de la détection principale parent. Les données de détection sont fournies via des info-bulles et des annotations de serveur. En outre, il est possible d'exporter les diagrammes au format de fichier Microsoft Visio®.

Annotations d'image de la topologie du serveur SMS

Icônes des types de serveurs

  • Type de serveur de base de données : base de données du site

  • Type de système de site : point de gestion

  • Type de serveur : site central, site principal, site secondaire et système de site

Lignes de connecteur

La couleur et le style d'une ligne de connecteur indiquent le type de relation entre deux ordinateurs :

  • Le connecteur entre deux serveurs de site est une ligne noire.

  • Le connecteur entre un serveur de site et un système de site est une ligne pointillée bleue.

Voir aussi

Concepts

Ressources supplémentaires pour le Microsoft Systems Management Server 2003 Management Pack
Groupes d’ordinateurs pour SMS 2003
Fournisseurs de SMS 2003
Diagrammes SMS 2003
Rapports SMS 2003

Autres ressources

Sites et composants du SMS 2003 Management Pack
Groupes de règles SMS 2003
Scripts pour SMS 2003
Affichages Microsoft SMS 2003


Rapports SMS 2003

Les rapports décrits dans cette section sont disponibles dans le SMS 2003 Management Pack. L'outil de rapports (Reporting) est un composant en option à installer séparément. Pour plus d'informations sur le déploiement du serveur de rapports, voir la page Web du produit Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).

Rapports SMS

Le Systems Management Server 2003 Management Pack intègre trois types de rapports :

  • Performances

  • Configuration

  • Disponibilité

Les rapports sont ciblés sur des groupes ou des objets à l'aide du sélecteur d'objets. Tous les rapports sont des rapports liés qui tirent profit des fonctionnalités de rapport d'Operations Manager 2007. Vous avez le choix entre sept formats de rapport exportables.

Rapports de disponibilité

Le SMS 2003 Management Pack intègre trois rapports de disponibilité, qui peuvent être exécutés sur le groupe cible du sélecteur d'objets Microsoft.SMS.2003.ServersGroup. Pour cela, sélectionnez le groupe de serveurs SMS (Microsoft.SMS.2003.ServersGroup).

Rapport de disponibilité du serveur

Le rapport de disponibilité du serveur repose sur l'état de fonctionnement agrégé de toutes les entités d'un serveur donné. Ce rapport contient les états de fonctionnement des rôles d'analyse SMS et de tous les autres rôles analysés.

Disponibilité du serveur de site

Le rapport de disponibilité du serveur de site repose sur l'état de fonctionnement d'un serveur de site. Ce rapport utilise des informations issues de l'analyseur d'état de fonctionnement.

Rapport de disponibilité du point de gestion

Le rapport de disponibilité du point de gestion repose sur l'état de fonctionnement d'un point de gestion. Ce rapport utilise des informations issues de l'analyseur d'état de fonctionnement.

Rapport de configuration

Le SMS 2003 Management Pack intègre un rapport de configuration, à savoir le rapport de configuration cliente du serveur SMS 2003. Il s'agit d'un rapport de configuration personnalisé de base contenant les propriétés d'un serveur SMS ou d'un groupe de serveurs SMS.

Ce rapport affiche les propriétés SMS suivantes :

  • Version (version du produit SMS)

  • Type de système de site (type de système de site, type de serveur, type de serveur de base de données)

  • Composants (serveur de site, point de recherche de serveur, point de distribution, point de gestion, point de rapport, serveur de base de données, fournisseur, expéditeur, point d'accès client)

  • Code du site (code du site SMS)

  • Type de serveur (serveur de site central, principal, secondaire)

  • Nom (nom NetBIOS)

  • Type de serveur de base de données (serveur de base de données du site)

Ce rapport peut être exécuté sur le groupe cible du sélecteur d'objets Microsoft.SMS.2003.ServersGroup.

Performances

Les rapports de performance ont été regroupés en unités reposant d'abord sur le rôle de site analysé, puis sur les compteurs, selon qu'il s'agit de compteurs de performance par taux (par seconde ou par minute, par exemple) ou de compteurs bruts (totaux). Ce regroupement garantit que tous les compteurs d'un rapport utilisent une échelle similaire.

Les rapports ont été élaborés d'après le type d'analyse requis. Deux ensembles de rapports sont disponibles : l'un affiche tous les compteurs de performance pour un rôle serveur SMS donné (point de gestion ou serveur de site, par exemple), tandis que l'autre affiche tous les compteurs pour un objet de traitement donné (inventaire matériel, par exemple) pour tous les rôles de site.

Rapports du groupe de performance du serveur SMS 2003

Pour exécuter les rapports ci-dessous, sélectionnez Microsoft.SMS.2003.ServerPerformanceGroup dans le groupe cible du sélecteur d'objets.

Performance brute des enregistrements de données de découverte (DDR) SMS 2003

Ce rapport affiche les enregistrements de données de découverte (DDR) en retard de traitement et les totaux traités pour tous les rôles serveur SMS applicables.

Mesure de performance SMS 2003 : enregistrements de données de découverte (DDR) en retard de traitement sur le serveur de site | Total de DDR mis en file
Mesure de performance SMS 2003 : nombre total d'enregistrements de données de découverte du serveur de site traités | Total de DDR traités
Mesure de performance SMS 2003 : enregistrements de données de découverte du point de gestion en retard de traitement | Messages en attente
Mesure de performance SMS 2003 : Gestionnaire de découverte du point de gestion (nbre total de rapports) | Nombre total de rapports
Mesure de performance SMS 2003 : nombre total d'enregistrements DDR DMP traités | Nombre total de rapports de découverte générés

Taux de performance des enregistrements de données de découverte (DDR) SMS 2003

Ce rapport affiche les taux de traitement des enregistrements de données de découverte (DDR) pour tous les rôles serveur SMS applicables.

Mesure de performance SMS 2003 : taux de traitement des enregistrements de données de découverte du serveur de site | DDR traités/minute
Mesure de performance SMS 2003 : Gestionnaire de découverte du point de gestion (nbre total de rapports par seconde) | Nombre total de rapports par seconde
Mesure de performance SMS 2003 : taux de traitement des enregistrements de données de découverte DMP | Rapports de découverte générés par seconde

Performance brute des inventaires matériels (HINV) SMS 2003

Ce rapport affiche les inventaires matériels (HINV) en retard de traitement et les totaux traités pour tous les rôles serveur SMS applicables.

Mesure de performance SMS 2003 : inventaires matériels du serveur de site en retard de traitement | Total de MIF en file
Mesure de performance SMS 2003 : nombre total d'inventaires matériels du serveur de site traités | Total de MIF traités
Mesure de performance SMS 2003 : inventaires matériels du point de gestion en retard de traitement | Messages en attente
Mesure de performance SMS 2003 : Gestionnaire d'inventaire matériel du point de gestion (nbre total de rapports) | Nombre total de rapports
Mesure de performance SMS 2003 : nombre total d'inventaires matériels DMP traités | Nombre total de rapports d'inventaire matériel générés

Taux de performance des inventaires matériels (HINV) SMS 2003

Ce rapport affiche les taux de traitement des inventaires matériels (HINV) pour tous les rôles serveur SMS applicables.

Mesure de performance SMS 2003 : taux de traitement des inventaires matériels du serveur de site | MIF traités/minute
Mesure de performance SMS 2003 : Gestionnaire d'inventaire matériel du point de gestion (nbre total de rapports par seconde) | Nombre total de rapports par seconde
Mesure de performance SMS 2003 : Gestionnaire de nouvel inventaire matériel du point de gestion (nbre total de rapports par seconde) | Nombre total de rapports par seconde
Mesure de performance SMS 2003 : taux de traitement des inventaires matériels DMP | Rapports d'inventaire matériel générés par seconde

Performance brute des inventaires logiciels (SINV) SMS 2003

Ce rapport affiche les inventaires logiciels (SINV) en retard de traitement et les totaux traités pour tous les rôles serveur SMS applicables.

Mesure de performance SMS 2003 : inventaires logiciels du serveur de site en retard de traitement | Total de SINV en file
Mesure de performance SMS 2003 : nombre total d'inventaires logiciels du serveur de site traités | Total de SINV traités
Mesure de performance SMS 2003 : collectes de fichiers du point de gestion en retard de traitement | Messages en attente
Mesure de performance SMS 2003 : inventaires logiciels du point de gestion en retard de traitement | Messages en attente
Mesure de performance SMS 2003 : Gestionnaire d'inventaire logiciel du point de gestion (nbre total de rapports) | Nombre total de rapports
Mesure de performance SMS 2003 : nombre total d'inventaires logiciels DMP traités | Nombre total de rapports d'inventaire logiciel générés

Taux de performance des inventaires logiciels (SINV) SMS 2003

Ce rapport affiche les taux de traitement des inventaires logiciels (SINV) pour tous les rôles serveur SMS applicables.

Mesure de performance SMS 2003 : taux de traitement des inventaires logiciels du serveur de site | SINV traités/minute
Mesure de performance SMS 2003 : Gestionnaire d'inventaire logiciel du point de gestion (nbre total de rapports par seconde) | Nombre total de rapports par seconde
Mesure de performance SMS 2003 : Gestionnaire de collecte de fichiers d'inventaire logiciel du point de gestion (nbre total de rapports par seconde) | Nombre total de rapports par seconde
Mesure de performance SMS 2003 : taux de traitement des inventaires logiciels DMP | Rapports d'inventaire logiciel générés par seconde

Performance des ressources système du serveur SMS 2003

Ce rapport affiche l'utilisation des ressources système par rôle serveur SMS.

Mesure de performance SMS 2003 : mémoire - % d'octets alloués en cours d'utilisation | Octets alloués en cours d'utilisation
Mesure de performance SMS 2003 : fichier d'échange - % d'utilisation | Pourcentage d'utilisation
Mesure de performance SMS 2003 : processeur - % Temps processeur (_Total) | % Temps processeur
Mesure de performance SMS 2003 : processeur - % Temps processeur (smsexec) | % Temps processeur
Mesure de performance SMS 2003 : processeur - % Temps processeur (ccmexec) | % Temps processeur
Mesure de performance SMS 2003 : système - Temps d'activité du système | Temps d'activité système

Performance brute des contrôles de logiciel (SWM) SMS 2003

Ce rapport affiche les contrôles de logiciel (SWM) en retard de traitement et les totaux traités pour tous les rôles serveur SMS applicables.

Mesure de performance SMS 2003 : contrôle de logiciel en retard de traitement sur le serveur de site | Nombre total de fichiers d'utilisation SWM en file d'attente
Mesure de performance SMS 2003 : nombre total de contrôles de logiciel du serveur de site traités | Nombre total d'enregistrements d'utilisation SWM traités
Mesure de performance SMS 2003 : retard de traitement du Gestionnaire de relais du point de gestion | Messages en attente
Mesure de performance SMS 2003 : Gestionnaire de relais de point de gestion (nbre total de rapports) | Nombre total de rapports

Taux de performance des contrôles de logiciel (SWM) SMS 2003

Ce rapport affiche les taux de traitement des contrôles de logiciel (SWM) pour tous les rôles serveur SMS applicables.

Mesure de performance SMS 2003 : taux de traitement des contrôles de logiciel du serveur de site | Enregistrements d'utilisation SWM traités/minute
Mesure de performance SMS 2003 : Gestionnaire de relais du point de gestion (nbre total de rapports par seconde) | Nombre total de rapports par seconde

Performance brute des messages d'état SMS 2003

Ce rapport affiche les messages d'état SMS en retard de traitement et les totaux traités pour tous les rôles serveur SMS applicables.

Mesure de performance SMS 2003 : nombre total de messages d'état du serveur de site traités | Reçu
Mesure de performance SMS 2003 : messages d'état du point de gestion en retard de traitement | Messages en attente
Mesure de performance SMS 2003 : Gestionnaire d'état de point de gestion (nbre total d'événements) | Total des événements
Mesure de performance SMS 2003 : nombre total de messages d'état DMP traités | Nombre total de messages d'état générés

Taux de performance des messages d'état SMS 2003

Ce rapport affiche les taux de traitement des messages d'état SMS pour tous les rôles serveur SMS applicables.

Mesure de performance SMS 2003 : taux de traitement des messages d'état du serveur de site | Traité/s
Mesure de performance SMS 2003 : Gestionnaire d'état de point de gestion (nbre total d'événements par seconde) | Nb total d'événements par seconde
Mesure de performance SMS 2003 : taux de traitement des messages d'état DMP | Messages d'état générés par seconde

Performance de prise en charge des rôles serveur SMS 2003

Ce rapport affiche la performance des services prenant en charge les rôles serveur SMS.

Mesure de performance SMS 2003 : service Web (Demandes d'extension ISAPI par seconde) | Requêtes d'extension ISAPI/s
Mesure de performance SMS 2003 : connexions SQL SMS | Connexions utilisateur

Rapports des serveurs Point de gestion SMS 2003

Pour exécuter les rapports ci-dessous, sélectionnez Serveurs Point de gestion Microsoft dans le groupe cible du sélecteur d'objets.

Performance brute du point de gestion de périphériques SMS 2003

Ce rapport affiche les totaux traités pour le rôle serveur Point de gestion de périphériques SMS.

Mesure de performance SMS 2003 : nombre total d'enregistrements DDR DMP traités | Nombre total de rapports de découverte générés
Mesure de performance SMS 2003 : nombre total d'inventaires matériels DMP traités | Nombre total de rapports d'inventaire matériel générés
Mesure de performance SMS 2003 : nombre total d'inventaires logiciels DMP traités | Nombre total de rapports d'inventaire logiciel générés
Mesure de performance SMS 2003 : nombre total de messages d'état DMP traités | Nombre total de messages d'état générés
Mesure de performance SMS 2003 : nombre total de demandes ISAPI DMP envoyées | Nombre total de messages envoyés
Mesure de performance SMS 2003 : nombre total de demandes ISAPI DMP reçues | Nombre total de messages reçus

Taux de performance du point de gestion de périphériques SMS 2003

Ce rapport affiche les taux de traitement pour le rôle serveur Point de gestion de périphériques SMS.

Mesure de performance SMS 2003 : taux de demandes de paramètres DMP | Demandes de paramètres DMP par seconde
Mesure de performance SMS 2003 : taux de demandes de paramètres d'ordinateur DMP | Demandes de paramètres d'ordinateur par seconde
Mesure de performance SMS 2003 : taux de demandes d'ID de stratégie logicielle DMP | Demandes d'ID de stratégie logicielle par seconde
Mesure de performance SMS 2003 : taux de demandes de corps de stratégie logicielle DMP | Demandes de corps de stratégie logicielle par seconde
Mesure de performance SMS 2003 : taux de demandes de version de package DMP | Demandes de version de package par seconde
Mesure de performance SMS 2003 : taux de demandes de conversion de données de découverte DMP | Demandes de conversion de données de découverte par seconde
Mesure de performance SMS 2003 : taux de demandes de conversion d'inventaires matériels DMP | Demandes de conversion d'inventaires matériels par seconde
Mesure de performance SMS 2003 : nombre de tentatives de connexion à la base de données DMP | Tentatives de connexion à la base de données par seconde
Mesure de performance SMS 2003 : taux de traitement des enregistrements de données de découverte DMP | Rapports de découverte générés par seconde
Mesure de performance SMS 2003 : taux de traitement des inventaires matériels DMP | Rapports d'inventaire matériel générés par seconde
Mesure de performance SMS 2003 : taux de traitement des demandes d'emplacement du GD DMP | Demandes d'emplacement générées par seconde
Mesure de performance SMS 2003 : taux de traitement des messages ISAPI DMP | Messages envoyés par seconde
Mesure de performance SMS 2003 : taux de traitement des inventaires logiciels DMP | Rapports d'inventaire logiciel générés par seconde
Mesure de performance SMS 2003 : taux de traitement des messages d'état DMP | Messages d'état générés par seconde

Performance brute du point de gestion SMS 2003

Ce rapport affiche les retards de traitement et les totaux traités pour le rôle serveur Point de gestion SMS.

Mesure de performance SMS 2003 : enregistrements de données de découverte du point de gestion en retard de traitement | Messages en attente
Mesure de performance SMS 2003 : Gestionnaire de découverte du point de gestion (nbre total de rapports) | Nombre total de rapports
Mesure de performance SMS 2003 : inventaires matériels du point de gestion en retard de traitement | Messages en attente
Mesure de performance SMS 2003 : Gestionnaire d'inventaire matériel du point de gestion (nbre total de rapports) | Nombre total de rapports
Mesure de performance SMS 2003 : collectes de fichiers du point de gestion en retard de traitement | Messages en attente
Mesure de performance SMS 2003 : inventaires logiciels du point de gestion en retard de traitement | Messages en attente
Mesure de performance SMS 2003 : Gestionnaire d'inventaire logiciel du point de gestion (nbre total de rapports) | Nombre total de rapports
Mesure de performance SMS 2003 : retard de traitement du Gestionnaire de relais du point de gestion | Messages en attente
Mesure de performance SMS 2003 : Gestionnaire de relais de point de gestion (nbre total de rapports) | Nombre total de rapports
Mesure de performance SMS 2003 : messages d'état du point de gestion en retard de traitement | Messages en attente
Mesure de performance SMS 2003 : Gestionnaire d'état de point de gestion (nbre total d'événements) | Total des événements

Taux de performance du point de gestion SMS 2003

Ce rapport affiche les taux de traitement pour le rôle serveur Point de gestion SMS.

Mesure de performance SMS 2003 : Gestionnaire d'emplacement du point de gestion (Demandes du point de gestion par seconde) | Requêtes du point de gestion par seconde
Mesure de performance SMS 2003 : Gestionnaire d'emplacement du point de gestion (Demandes du point de distribution par seconde) | Demandes DP/s
Mesure de performance SMS 2003 : obtention de stratégie de point de gestion (Demandes par seconde) | Demandes/s
Mesure de performance SMS 2003 : obtention d'authentification de point de gestion (Demandes par seconde) | Demandes/s
Mesure de performance SMS 2003 : Gestionnaire de stratégie de point de gestion (Demandes d'attribution de stratégie par seconde) | Requêtes d'attrib. de stratégie par seconde
Mesure de performance SMS 2003 : DAL du point de distribution (Procédures stockées exécutées par seconde) | Procédures stockées exécutées par seconde
Mesure de performance SMS 2003 : Gestionnaire d'inventaire matériel du point de gestion (nbre total de rapports par seconde) | Nombre total de rapports par seconde
Mesure de performance SMS 2003 : Gestionnaire de nouvel inventaire matériel du point de gestion (nbre total de rapports par seconde) | Nombre total de rapports par seconde
Mesure de performance SMS 2003 : Gestionnaire d'inventaire logiciel du point de gestion (nbre total de rapports par seconde) | Nombre total de rapports par seconde
Mesure de performance SMS 2003 : Gestionnaire de collecte de fichiers d'inventaire logiciel du point de gestion (nbre total de rapports par seconde) | Nombre total de rapports par seconde
Mesure de performance SMS 2003 : Gestionnaire de relais du point de gestion (nbre total de rapports par seconde) | Nombre total de rapports par seconde
Mesure de performance SMS 2003 : Gestionnaire d'état de point de gestion (nbre total d'événements par seconde) | Nb total d'événements par seconde

Voir aussi

Concepts

Ressources supplémentaires pour le Microsoft Systems Management Server 2003 Management Pack
Groupes d’ordinateurs pour SMS 2003
Fournisseurs de SMS 2003
Diagrammes SMS 2003
Rapports SMS 2003

Autres ressources

Sites et composants du SMS 2003 Management Pack
Groupes de règles SMS 2003
Scripts pour SMS 2003
Affichages Microsoft SMS 2003